WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Posting to Facebook (10 posts)

  1. backyarder1
    Member
    Posted 10 months ago #

    I have the Sharing tool setup to automatically post my posts to Facebook, twitter, etc. Sometimes it posts the title of the blog post and a photo. Other times, it posts the URL instead of the title and no photo.

    Here is a screenprint that shows an example:
    http://www.backyardbrevard.com/?attachment_id=2330

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    When you share a post on Facebook, or when Jetpack Publicize publishes a post to your Facebook page, Facebook crawls the page and looks for Open Graph meta tags in the head to build a complete post preview (with an image, title, description, ...).

    You can see what Facebook sees by entering one of your posts' URLs in Facebook Debugger:
    https://developers.facebook.com/tools/debug

    Jetpack automatically adds such Open Graph meta tags, except if you use another plugin to handle these.

    Looking at your site, it seems that you do indeed use another plugin, as the Jetpack Open Graph meta tags are not displayed. However, that plugin must not be configured properly, as it doesn't add the tags to your posts at the moment.

    Check your list of active plugins and you should find one of the following plugins:

    Official Facebook plugin
    WordPress SEO by Yoast
    Add Link to Facebook
    Facebook AWD All in one
    Header and Footer
    NextGEN Facebook OG
    SEO Facebook Comments
    SEO Ultimate
    SexyBookmarks
    Shareaholic
    Social Discussions
    NextScripts SNAP
    Wordbooker
    Socialize
    Simple Facebook Connect
    Social Sharing Toolkit
    WP Facebook Open Graph protocol
    Open Graph
    SharePress

    One of them can be configured to add Open graph meta tags to your posts.

    Let me know if it helps.

  3. backyarder1
    Member
    Posted 10 months ago #

    I do use NextScripts SNAP to reach the services that Jetpack doesn't go to. Are you saying that I should use that service to publicize my Facebook posts rather than Jetpacks Sharing function, to get it to post correctly? Some of them work and some of them don't, using JetPack Sharing.

  4. backyarder1
    Member
    Posted 10 months ago #

    I used the Facebook debug tool that you suggested above, both on a post that WAS posting correctly to Facebook and one that wasn't. They both returned the same error: Error parsing input URL, no data was scraped.

  5. backyarder1
    Member
    Posted 10 months ago #

    Is there any other way to add open graph meta tags to my posts to fix this problem?

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    I do use NextScripts SNAP to reach the services that Jetpack doesn't go to. Are you saying that I should use that service to publicize my Facebook posts rather than Jetpacks Sharing function, to get it to post correctly?

    You can still use Jetpack Publicize. However, NextScripts SNAP includes options to add Open Graph meta tags to your posts. You should set these options, so that Facebook can gather information about your posts when crawling your posts.

  7. backyarder1
    Member
    Posted 10 months ago #

    Thanks so much Jeremy. I will post something today and see if that helps.

    I love your "job title" by the way. I used to work in computer support and it did kind of make me feel like a happiness engineer. Now I am more of a happiness promulgator.

    Betsy
    http://www.backyardbrevard.com

  8. backyarder1
    Member
    Posted 10 months ago #

    It seems to be working a lot better now except that it isn't including the photo from the post. Is there a way to correct that problem?

    Thanks

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    I see you have managed to add the meta tags via NextScripts SNAP:
    http://i.wpne.ws/PpV1

    However, and as you can see on the screenshot, the image meta tag is not correct; it leads to a small image (1px-1px) on Amazon:
    http://www.assoc-amazon.com/e/ir?t=thewildlifeha-20&l=as2&o=1&a=B003TLMR76

    I'm not sure how you added that image to your meta tags; if you don't know how to insert a proper image through NextScripts SNAP, I would suggest that you contact the plugin author about this issue.

  10. backyarder1
    Member
    Posted 10 months ago #

    Thanks. SNAP says that it is supposed to use the Featured image but it apparently isn't doing so. You can close this out as Solved. I'm not sure how to do that.

Reply

You must log in to post.

About this Plugin

About this Topic