WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Page Publish
[resolved] Posting Media code in excerpt. (5 posts)

  1. macbros
    Member
    Posted 3 years ago #

    Whenever I post something with a media file like a movie it shows the code of the player and not the content text.

    Here's an example of what gets posted.
    swfobject.embedSWF('http://fpdownload.adobe.com/strobe/FlashMediaPlayback_101.swf', 'flashcontent7634', '515', '320', '10.1.0', 'http://www.macbrosplace.com/******/expressinstall.swf', {src:'http%3A%2F%2Fwww.macbrosplace.com%2Fvideo%2F01-super8-1970s-MacDonald-Ewert-Family.mp4', controlBarMode:'docked',...

    You can see an example of the FB page here;
    http://www.facebook.com/pages/MacBros-Place/165075643547144?sk=wall

  2. macbros
    Member
    Posted 3 years ago #

    Is there any support for this?

  3. mtschirs
    Member
    Plugin Author

    Posted 3 years ago #

    Hi macbros,

    I was quite busy, so my reply is a bit late. I see that you are using another plugin now, but nevertheless it would be great if you could help me fix the bug. Could you tell me how you post the media file - is it a custom short code or another plugin ?

    Thank you,
    mtschirs

  4. macbros
    Member
    Posted 3 years ago #

    short code with plug-in. Flash Media player.
    I'm still using your plug in, I'm actually in the process of changing things around on my site and will be turning it back on again shortly.

    But if you could get it to ignore the media coding, and just show the regular text in the excerpt that would be great.

    Also, it displays the URL's of images and Links too. If you have an image in the top portion of the post it displays the Image URL in the excerpt and the same thing for links too, so it's not just Media, it's simple images and links also.

  5. mtschirs
    Member
    Plugin Author

    Posted 2 years ago #

    Hi macbros,

    The Flash Media Player problem is fixed in version 0.3.8 (Javascript code is now removed). If you do not want to have link and image urls in your post on Facebook, go to the plugin settings (section 3) and uncheck the two relevant checkboxes.

    Thank you,
    mtschirs

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic