WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Posting comments problem - Method Not Implemented (9 posts)

  1. shernade
    Member
    Posted 8 months ago #

    Hello,
    first of all, thanks to jetpack team. I think its a powerful plugin.

    Now my history:

    Before I install jetpack, I was having a blank page posting comments in my blog http://www.hornodeluna.es, Then I installed jetpack and make many test. With Jetpack installed, jetpack comments and google adsense plugin turned off I can put comments in my blog, but if I turn on jetpack comments or google adsense plugin, I have the 501 error:
    Method Not Implemented

    POST to /wp-comments-post.php not supported.

    In other thread i read many about .htaccess problem, but i don't know exactly. I set .htaccess to the basic but the problem still continues.

    Of course if I disable all the plugins there's no problem.

    Someone can help me?

    Thanks a lot and sorry for my English,
    Sergio.

    http://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 8 months ago #

    Could you try to deactivate any other comment, captcha, or anti-spam plugins currently installed on your site?

    If you do not use such plugins, could you give me a list of all active plugins on your site at the moment?

    Thanks!

  3. shernade
    Member
    Posted 8 months ago #

    A just try disabling:
    Akismet, Antispam Bee, LĂ­mitador de intentos de login (limit login attempts)
    And enabling jetpack comments but the problem still continues.

    Here's mi plugin list
    And this is my htaccess file.

    Before this problem, i also have the wonderful plugin w3 total cache, but i also disable (and remove) this problem but maintain the .htaccess config.

    Thanks a lot,
    Sergio.

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 8 months ago #

    Could you try to disable Antispam Bee? This plugin is not compatible with Jetpack Comments.

  5. shernade
    Member
    Posted 8 months ago #

    I just disable (and remove) Antispam Bee, and set .htaccess to the minimum:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    And the problem continues.

    I set the jetpack comments active, so you can see it.

    Thanks,
    Sergio

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 8 months ago #

    Could you try to switch to a one of the default themes for a few minutes, and see if it helps?

  7. shernade
    Member
    Posted 8 months ago #

    same problem with pinboard theme active just now.
    tell me when you see it and I return to previous.

  8. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 8 months ago #

    Thanks.

    This could be related to your server configuration settings.

    Could you contact your hosting provider and let them know about the issue? You can point them to this post for more information:
    http://weblogtoolscollection.com/archives/2008/02/12/modsecurity-wordpress-admin-and-method-not-implemented/

    Let me know if it helps.

  9. shernade
    Member
    Posted 8 months ago #

    thanks, i'll first read that link and try the solutions. After that i'll contact my hosting provider.
    i'll let you know, thanks a lot.

Reply

You must log in to post.

About this Plugin

About this Topic