WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Posting comments not working (5 posts)

  1. cmykaye
    Member
    Posted 1 year ago #

    I've created a custom theme which is working great, but when I try to post a comment, I get this error:

    Warning: call_user_func() expects parameter 1 to be a valid callback, function 'twentyeleven_comment' not found or invalid function name in /home/kayehuet/public_html/home/wp-includes/comment-template.php on line 1334

    I'm using the twentyeleven comments.php, but not sure if I need to amend anything to get it to work?

  2. Tara
    Member
    Posted 1 year ago #

    - To rule out any theme-specific issue, try switching to the unedited default theme for a moment using the WP dashboard. If you don't have access to your admin area, you can switch to the default theme by renaming your current theme's folder in wp-content/themes via FTP or SFTP or whatever file management application your host provides.

  3. cmykaye
    Member
    Posted 1 year ago #

    Okay, it is working fine with the default theme.

  4. Tara
    Member
    Posted 1 year ago #

    Okay, it is working fine with the default theme.

    This means your custom theme is broken.

  5. cmykaye
    Member
    Posted 1 year ago #

    Yes, and I'm searching for help to try and fix it. Everything else is working fine. I only get an error when I try to post a comment. :/

Topic Closed

This topic has been closed to new replies.

About this Topic