WordPress.org

Ready to get started?Download WordPress

Forums

Posting a Comment Leads to 404 (23 posts)

  1. Eon-Rider
    Member
    Posted 4 years ago #

    For the past week, my blog has been redirecting to me and any guests who try to comment to a 404 error page. I don't think I've made any major changes to my blog. The only thing I've done with my blog in terms of editing it is changing a small CSS value to the paragraph (p) tag. Styles can't possibly affect the way comments can they?

    I was on 2.8.1 when this started happening. I did an auto-update just now and the comment issue continues to persist.

    Can someone help me with my problem?

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems.

  3. Eon-Rider
    Member
    Posted 4 years ago #

    Actually yes I have tried both. They were the first things I did. Neither helped.

  4. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Try renaming the plugins folder via FTP. Sometimes even "inactive" plugins can continue to cause problems. It's definitely not your CSS changes.

    Check that the last 3 lines in the <head></head> section of header.php end with:

    <?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>
    <?php wp_head(); ?>
    </head>

    Also check that immediately before the </form> in comments.php, you have the line:
    <?php do_action('comment_form', $post->ID); ?>

    You might also want to try re-uploading a fresh copy of wp-includes and wp-comments-post.php. There's definitely something wrong with the address that's generated used after a comment is posted:

    http://www.kablooza.co.cc/comment-page-#comment-

  5. Eon-Rider
    Member
    Posted 4 years ago #

    I've tried all of those options and none of them worked. I even tried uploading the whole WordPress package again and my problem wasn't resolved.

    >.>

    I'm willing to give you access to my account if you'll help me.

  6. Eon-Rider
    Member
    Posted 4 years ago #

    *sigh*

    I still haven't resolved my issue even after uploading the whole WordPress package three times.

  7. Zulfikar Nore
    Member
    Posted 4 years ago #

    I take a look at your blog if you want.
    mail to admin@bloginstallationservice.com

    Zulf

  8. Eon-Rider
    Member
    Posted 4 years ago #

    Hmm... Can I really trust you?

    Also, just for the record, I've typed "comment-page-#comment-" into Google and found people experiencing similar problems. I now realise it's a problem with the database which is why reuploading the whole WordPress package solves nothing.

  9. Zulfikar Nore
    Member
    Posted 4 years ago #

    Well as with any other security sensitive work it all comes down to trust. I assure you my intentions are honourable and I run my business with integrity so am not about to risk it for petty things.

    I advise all my customers as well as those whome I help to set up dummy users with rights and once the work is done to delete thsoe users.

    At the end of the day it is upto you to trust or not to, am just offering to help out a fellow blogger on the merit of this great forum. Otherwise I charge for such services on my site.

  10. Eon-Rider
    Member
    Posted 4 years ago #

    Yes, I realise all of that. I have provided you with access to my account.

  11. mtnbikechk
    Member
    Posted 4 years ago #

    I just created a blog for a friend and was having the 404 error message after someone tried to comment. I called my hosting company, BlueHost and they were able to help me figure out it was my permalink. Originally I had entered it as /%postname%/ but after talking to the extremely helpful guy at BlueHost we changed it to /%postname% notice that we ditched the last /

    Not sure if you are using this type of permalink, but it sure fixed my problem.

    Good luck.

  12. jacob432
    Member
    Posted 4 years ago #

    i had the exact same problem and the solution from mtnbikechk (last commenter0 was exactly what helped me solve it. I depeted the one trailing slash in my permalinks and then the redirect after commenting worked again.

  13. iluminada
    Member
    Posted 4 years ago #

    I'm having this issue as well, and have performed all of the above troubleshooting suggestions, without a resolution. I have also tried activating new themes. The really strange thing is that spammers are still injecting comment spam from time-to-time, but legit registered users get a 404 when posting a comment. I'm totally stumped.

    I've also tried replacing my theme's comments.php file and my root wp-comments-post.php file. I am running 2.8.5, but the problem began with 2.8.1.

    Any further suggestions will be greatly appreciated.

  14. iluminada
    Member
    Posted 4 years ago #

    Found the cause: wp-comments-post.php had the wrong permissions set. Not sure how it got that way (I didn't manually change it), but it needs to be set to 644.

  15. idleberg
    Member
    Posted 4 years ago #

    i'm currently having the same problem.

    changing the permalink structure only changed the url of the 404 page:

    http://myblog.com/comment-page-#comment-
    instead of
    http://myblog.com/comment-page-/#comment-

    changing the permissions to 644 did not have any effect. the same theme is working perfectly on wordpress, the problem only occurs on wordpress-mu.

    any other ideas?

  16. idleberg
    Member
    Posted 4 years ago #

    ps: i have tried using comments.php from the default theme - no change. will go through the plugins now :(

  17. idleberg
    Member
    Posted 4 years ago #

    after some further testing i came to the conclusion, that the problem is not the version of wordpress or the theme. it all works using a fresh installation of wordpress and wordpress mu. so it must be in my database.

    logged in users can post comments, everybody else can't (-> 404). i also tried to transfer my comments to disqus and intensedebate. in either case the import did not happen at all.

    what else can i do? :(

  18. roberthq
    Member
    Posted 4 years ago #

    Maybe add a custom 404 file that says the comments has been sent and give a link back to the home page.

  19. techmuse
    Member
    Posted 4 years ago #

    This does appear to be a Database issue. Install the WP-DB Manager Plugin.

    Back up your database, then repair and optimize it using the provided tools. Most likely this will do the trick! Then depending on the size of your database do this on a regular basis to keep things humming.

    HTH! ;-)

  20. techmuse
    Member
    Posted 4 years ago #

    If you still have problems, uncheck "Break comments into pages..." in Settings > Discussions. HTH!

  21. mogston
    Member
    Posted 3 years ago #

    Hi everyone- had a very similar problem today - the problem appeared without any changes to the WordPress installation: when publishing a new comment users were receiving a 404. I Looked at the comments DB table and for some reason it had stopped auto-incrementing itself.

    I changed the ‘comment_ID’ id column to Auto Increment and it seems to work okay now. New comments are saving correctly.

  22. ergodicray
    Member
    Posted 3 years ago #

    I was experiencing the same issue: 404 page on comment posting, but additionally, all the comments previously on my site had disappeared, neither listed in dashboard or viewable on the pages themselves.

    I tried the methods mentioned: disabling plugins, changing themes, checking permalinks, htaccess rewrite rules, and file permissions, and upgrading WP... none of them worked. It turned out that the problem was my WP comments table had crashed.

    It looks like WP-DB Manager Plugin doesn't have a version for WP 3, so here's a link on how to fix crashed tables quickly if you have shell access to the wp database files: How to repair a crashed wordpress database

  23. dariusk
    Member
    Posted 3 years ago #

    I can confirm that repairing the wp_comments table fixed this exact problem for me (running 2.9.2). I didn't have permissions to repair tables directly on my shared host, but I installed the wp-dbmanager plugin and ran the repair on the table from there. Problem solved!

Topic Closed

This topic has been closed to new replies.

About this Topic