WordPress.org

Ready to get started?Download WordPress

Forums

postie install (11 posts)

  1. grillrepair
    Member
    Posted 1 year ago #

    trying to install postie. when i activate the tool and go into settings the drop-down selection only shows "pop3" and pop-ssl and imap and imap-ssp are not available which i guess (??) means i cannot use gmail.

    OK so i created an email from my domain. it uses pop so i add user name, password (sent and received mail at new address to make sure it is working) made the port 110 and the server mail.domain.com.

    I have done this several times and looked to make sure of the server, port, password, etc. The only thing i have been unsure of is whether to use the user name or "admin" for the user name so i tried it twice. the user name is designated an admin but i do not know if that i what it's asking for. But tried it both ways.

    i keep getting the same error message:

    Test Result
    Connect to Mail Host Unable to connect. The server said - POP3 connect: Error [110] [Connection timed out]
    Try putting in your full email address as a userid and try again.

    then i changed the user name to the full email address like: username@domain.com
    but i keep getting the same error message.
    Anyone know what I can do to get this to work?

  2. Abhishek Ghosh
    Member
    Posted 1 year ago #

    Postie official documentation says the answer.

    http://wordpress.org/extend/plugins/postie/faq/

    If you have root access, install own mail server (if already not installed) software and usually it opens the port itself.

    Usually third party port requests are blocked by firewall by server administrators for security.

    It is difficult to configure if you do not have root access to the server.

  3. grillrepair
    Member
    Posted 1 year ago #

    thanks. i am the "webmaster" for the site. i set up the hosting, FTP, wrote the code and created the email for the domain. i do not think there is anything i do not have access to. i have hosting at network solutions. i created an email just to use with postie. i waited 30 minutes and sent/received email to make sure it was live.

    then i entered the data in the postie settings on the WP blog. i usually think if "third party" as yahoo, gmail, hotmail and that sort of thing. it that not true? i am using my own domain as the email.

    thanks!

  4. grillrepair
    Member
    Posted 1 year ago #

    the FAQ says "Make sure the port you are using is open." but i do not know what that means. i looked inthe NS email settings and it says to use:
    mail.dimain.com

    and port 110

    which is what i did. i added the user name and password and when i received the error i changed the user name to the full email but still received the same error.

  5. Abhishek Ghosh
    Member
    Posted 1 year ago #

    That info is for mobile devices or Windows PC / Mac / Linux mail software clients to send receive emails, our mobile, desktop firewall is set in that way. That is not for server side request. We need pop3-ssl or imap-ssl with a gmail account for setup, thats too often kept closed.

    i usually think if "third party" as yahoo, gmail, hotmail and that sort of thing. it that not true?

    Self is actually own hosted email software on that server or allowed by that server company's network. Yahoo! , Gmail, Hotmail etc. will not be allowed by the most as non ssl.
    admin@example.com is hosted on Gmail usually will not work with usual non ssl settings, thats why we use Gmail's pop3-ssl or imap-ssl credentials, still access is needed inside, though encrypted in the network through the port (usually 993) which can be closed by the administrator.

    It is about core networking security, server settings etc.

  6. grillrepair
    Member
    Posted 1 year ago #

    maybe the problem is the timer? i am unsure what it means but it was originally set at "-4". what it the story with the timer? can i set it to somehow accept the email as a post in real time?

  7. grillrepair
    Member
    Posted 1 year ago #

    i just saw the reply, thanks.
    when i activated postie the first drop down box in the "mailserver" tab only allows "pop3" the pop3-ssl and other settings are not an option.

    my own hosted email is pop so i do not imagine that would be a problem.
    i created a new email. i set up that email on my local machine "mail" software and it works fine with incoming 110.

    i have all the same data in postie but it is timing out.

    i also have gmail addresses but the postie instructions say that in order to use gmail i have to select something other than pop3 but only pop3 in available in the drop down box under the "mailserver" tab.

    from the default all i changed was mailserver (mail.domain.com) the user name (username@domain.com) the password and port 110. then i changed the admin name under the "user" tab. And i changed the category to one of my WP categories.

    i set up the mail address myself so there is no one else who would have created any firewalls or anything and i set the same fields in the local machine and it is sending and receiving from "mail" just fine.

    what else could i need to change in postie?

    thanks!

  8. Abhishek Ghosh
    Member
    Posted 1 year ago #

    i set up the mail address myself so there is no one else who would have created any firewalls or anything and i set the same fields in the local machine and it is sending and receiving from "mail" just fine.

    what else could i need to change in postie?

    Your local computer will work fine as (again that odd thing) the ports are open by default.

    Firewall is usually set at web host's data center router level.
    You can try with pop3-ssl (of gmail like Postie's instruction to set) with that pop3 option. This is the last combination, but I am quite sure it will not work too. If Postie fails, most other similar plugins will fail too. Basic mechanism / pathway is same.

    Basically you want to send blog updates as email. But technical the process is not so simple.

    That is what all wants and uses Google FeedBurner, MailChimp etc. for easy headache free setup. In other words, sending RSS feed as email is easier from a different server than from your WordPress as you or me do not have to configure the server security gateway part.

  9. grillrepair
    Member
    Posted 1 year ago #

    i appreciate that but i guess my understanding of this forum was to be able to use the wordpress plug-in not to prove it cannot be used so do something else.
    i really appreciate the assistance but i need to be able to get postie working. are we basically saying postie does not work?

    does it maybe just not work with a "real" email address?

    i went in and reset the settings using an email with gmail. now i have pop.gmail.com for the server, user name for the user id (gmail says to use the full email address so i did). i also changed the port to 995 because that is what gmail says to use in "set up pop in mail clients" and i went into my gmail settings, went to "forwarding and pop/imap" and clicked to "enable" pop in all mail.

    this time the error is:

    MAKE SURE POP IS TURNED ON IN SETTING AT Gmail

    Connecting to pop.gmail.com:995 (pop3))
    Mail Connection Time Out

    Common Reasons:

    Server Down

    Network Issue

    Port/Protocol MisMatch

    The Server Said POP3 connect: Error [110] [Connection timed out]

    _________________________________

    As mentioned i did check the pop setting in gmail and it is enabled. i also changed the port to 995 as gmail instructs so i do not know why the error says "error[110[". just to check i went back into postie settings and changed the port back to 110 and i got the same error except the "995" was a "110" in the error message. in the error message the second "110" was still a "110".

    does postie just not work at all?
    thank you.

  10. Abhishek Ghosh
    Member
    Posted 1 year ago #

    Postie works. Postie like Plugins works. But the setup needed ideally is own mail server.

    Most users of Postie or like Plugins are advanced users with good setup. They actually checks the setup by running command on SSH to check the situation. Additionally, the mail server is self hosted. There is full control. You can not restart gmail's mail server, for example.

    You are actually getting PHP output of the error, its hard to exactly say, at which level it is getting blocked. This is your web host can tell you. But from the output it appears the port is closed. Your web host is not allowing your WordPress to communicate outside through email via that port. There is difference in policies of various web hosts too.

    The thing is, not all plugins can support all server setup. This is the limitation of the technology behind we rent or buy with money. For example HyperDB is not for the most users.

    It will be better if you ask the plugin's support page to get direct reply from the developer :

    http://wordpress.org/support/plugin/postie

  11. grillrepair
    Member
    Posted 1 year ago #

    thanks. theres a forum within there where people seem to have it working. i'll get back into it in the morning. i've been at my office for 15 hours now and i have to take a break. thank you for the suggestions.

Topic Closed

This topic has been closed to new replies.

About this Topic