WordPress.org

Ready to get started?Download WordPress

Forums

Postie
Postie autocheck stoped working? (57 posts)

  1. ccbit
    Member
    Posted 1 year ago #

    I'm able to run postie manually with the button "Run postie". That works perfect. But the plugin doesn't work automatically. This has worked over months. I'm using WordPress 3.4.1 and postie 1.4.3.

    Has anyone the same issue?

    http://wordpress.org/extend/plugins/postie/

  2. gregcohen
    Member
    Posted 1 year ago #

    I've got the same issue. Let me know if you find a solution.

  3. ccbit
    Member
    Posted 1 year ago #

    I haven't found a solution so far. Postie is still not working in auto mode.

  4. chezpaul
    Member
    Posted 1 year ago #

    Same here

  5. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    I think I may have an answer for you. WordPress cron (which Postie relies on) doesn't run unless a page is accessed on the site. So if you send an email, but nobody accesses the site for 3 days Postie won't be given the chance to fetch the email and publish the post.

    To ensure that Postie runs smoothly on a low or no volume site you need to ensure that a page gets hit (any page is fine). Use something like cron + curl on Linux or install curl on Windows and use the Scheduled Tasks control panel.

    Wayne

  6. terrykiwi
    Member
    Posted 1 year ago #

    I have just installed Postie for the first time (v1.4.5) and it does not post automatically. I have to click the Run Postie button to import posts.

    I tested the above suggestion by flicking through a few pages on the blog before checking it, and it still didn't work.

    Any other ideas?

  7. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    @terrykiwi
    What is your "Check for mail every" set to? That amount of time needs to elapse before the WordPress cron will fire.

  8. terrykiwi
    Member
    Posted 1 year ago #

    I've tried them all. It is currently set for 10 minutes, but the only one that works is "check manually".

    It wouldn't be so bad if it was just me posting, but other contributors cannot rum Postie manually without admin rights.

  9. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Not to sound too basic, but I just want to understand what is happening.

    When you do the following, Postie is not reading the email.

    1) you send an email to the postie address
    2) you access the site (refresh home page)
    3) you wait more than 10 minutes
    4) you access the site again (refresh home page)

  10. terrykiwi
    Member
    Posted 1 year ago #

    Yes to all.

    In fact, I currently have 5 emails that have been waiting for several hours to be uploaded by Postie. During that time I have been doing many other things in WP, and frequently checking the results on the published blog.

  11. hmoore71
    Member
    Posted 1 year ago #

    @terrykiwi

    I would try if you can;
    http://domain/wp-cron.php

    This would be like a host cron script running.

    If that didn't do anything for your emails then I would try;

    http://domain/wp-contents/plugins/postie/get_email.php

    This is fundamentally what the postie cron hook does.

  12. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    I'd also use something like http://wordpress.org/extend/plugins/cron-view/ to see if something is clobbering the cron.

  13. terrykiwi
    Member
    Posted 1 year ago #

    Please elaborate. What do you want me to do with these files?

  14. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Cron-view is another plugin. Install it and look at the menu item it adds to see what cron jobs are scheduled. Tools -> What's in Cron?

  15. terrykiwi
    Member
    Posted 1 year ago #

    Without waiting for your answer about what to do with these files, I opened the first page link at the domain for my blog. It returned a blank page. I navigated through a few pages, waited 1/2 hour, and checked.The emails were still not uploaded to WP.

    I then tried the second link. It returned a 404.

  16. terrykiwi
    Member
    Posted 1 year ago #

    I also installed cron-view and I see nothing in their related to Postie. I don't know how to see if "something is clobbering the cron."

  17. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    1.4.6 was released yesterday. Please try upgrading and there are some directions for enabling debug mode.

  18. hmoore71
    Member
    Posted 1 year ago #

    @terrykiwi
    You did what I intended for you to do, that is access the scripts through the browser.

    If you had replaced "domain" with your website domain name and you got the those results then I suspect you don't either the proper address or perhaps access to run those php scripts.

    I'll let you work with Wayne on this and stand aside.

  19. terrykiwi
    Member
    Posted 1 year ago #

    Wayne:
    I installed 1.4.6 - no change.

    I'm not sure if I'm looking at the right directions for enabling debug mode. If you mean
    "define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('POSTIE_DEBUG', true);"
    then please tell me where in the wp-config.php file they should go (I'm not a programmer--I only know how to follow directions!).

    I read somewhere else that some hosting companies do not have the right settings enabled on the server to allow jobs like this to run. I could check with Hostgator, but I don't know what to ask/tell them. If this is a possibility, could you please advise me what to say to them?

    Thanks for hanging with me to get this resolved, as it is a very important link in my strategy for the blog.

  20. terrykiwi
    Member
    Posted 1 year ago #

    @hmoore71
    Those files should be opened in the root directory of the WP domain right? In my case domain.com/blog/

    Am I correct?

  21. terrykiwi
    Member
    Posted 1 year ago #

    @hmoore71

    I did find an error in your path to /wp-contents/plugins/postie/get_email.php

    It should be /wp-content/plugins/postie/get_email.php

    However it still returned a 404.

  22. hmoore71
    Member
    Posted 1 year ago #

    @terrykiwi
    For domain just append the wp-xxxx to your wordpress link;

    My wordpress link is http://indianbendsolutions.com

    So I would do http://indianbendsolutions.com/wp-cron.php
    or if I had Postie installed( I don't);
    http://indianbendsolutions.com/wp-content/plugins/postie/get_mail.php

    But I think it is best for you and Wayne work this out.

  23. terrykiwi
    Member
    Posted 1 year ago #

    @hmoore71
    @Wayne

    I successfully ran the get_mail.php file and Postie imported the email.

    Now what? What is the difference between running that manually every time I want to import the posts, and pressing the Run Postie button?

    Does this provide a clue as to why Postie isn't running automatically?

    I would sure love to put this issue to bed so I can move on and get some work done!

  24. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    @terrykiwi
    I did find a bug in the cron set up. I'll be releasing 1.4.7 shortly.

  25. chezpaul
    Member
    Posted 1 year ago #

    First of all, I'm glad there is so much discussion going on here. Most plugin devs don't give much thought about helping their users, Thanks Wayne

    Second, I want to second the fact that the automated process does not work for me either. I can send an email with attachement and wait and browse my site all day, nothing will happen, the post will not appear.

    If I then run it manually, sometimes I will get the post and sometimes it will tell me there are no emails. If I send one again and run the fetch manually right away then it sees the email.

    Another thing that happens. It will often for no reason tell me the email sending is not allowed to send posts when it is actually in the list of authorized emails.
    But that's another story that Wayne knows about. ;-)

    I hope this gets all figured out. ;-)

  26. hmoore71
    Member
    Posted 1 year ago #

    as @chezpaul said, Wayne is doing a heck of a job supporting this plugin
    and everyone using it should press the donate button.

  27. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    @chezpaul
    You are welcome, I appreciate the compliment.

    I fixed a bug in 1.4.7 (released today) I introduced with 1.4.5 that prevents the 10 min, 30 min and weekly schedules from running.

    Also in 1.4.6 I changed the XSS check to only be a warning since so many false positives were being detected.

    The authorized mail issue was fixed in 1.4.6.

  28. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    @hmoore71

    I'm glad you think so, thanks!

    Thanks to those who have already donated, it is appreciated.

    http://postieplugin.com/

  29. chezpaul
    Member
    Posted 1 year ago #

    Wow.. great... Thanks Wayne...
    Hope you're also looking into the custom html code thingy... ;-p
    Downloading now.

  30. terrykiwi
    Member
    Posted 1 year ago #

    I upgraded to 1.4.7.
    Sorry Wayne, but still no luck @ 30 minutes.

    I also set it to one hour since the implication in your earlier post was that there was nothing wrong with that setting. Still no emails imported. They are waiting in the email client. Again, I have no trouble importing when doing so manually.

    In each case I loaded several pages of the blog before checking.

    You have been very helpful and supportive. I appreciate it. What can we try next?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic