WordPress.org

Ready to get started?Download WordPress

Forums

Postie
Postie and Google Apps won't play (15 posts)

  1. WP Monkey
    Member
    Posted 1 year ago #

    I upgraded Postie AND switched our email to be hosted by Google Apps and now I can't get Postie to receive emails. I've tried switching the mail server, using SSL, listing the full email address, verifying the email and password, etc. and nothing seems to work.

    Here is a breakdown of the settings and error messages that I've been getting.

    POP3, Port 110, mailserver = mail.<domain>.org (Used to work)
    POP3, Port 110, mailserver = smtp.gmail.com

    Unable to connect. The server said - POP3 connect: Error [101] [Network is unreachable]
    Try putting in your full email address as a userid and try again.

    POP3, Port 110, mailserver = mail.gmail.com

    Unable to connect. The server said - POP3 connect: Error [0] [php_network_getaddresses: getaddrinfo failed: Name or service not known]
    Try putting in your full email address as a userid and try again.

    POP3-SSL, Port 995, mailserver = ssl://mail.<domain>.org

    Warning: imap_open() [function.imap-open]: Couldn't open stream {ssl://mail.<domain>.org:995/service=pop3/ssl/notls/novalidate-cert} in /home5/<domainname>/public_html/wp-content/plugins/postie/postieIMAP.php on line 78
    Unable to connect. The server said - Can't open mailbox {ssl://mail.<domain>.org:995/service=pop3/ssl/notls/novalidate-cert}: invalid remote specification
    Try putting in your full email address as a userid and try again.

    POP3-SSL, Port 995, mailserver = mail.<domain>.org

    Warning: imap_open() [function.imap-open]: Couldn't open stream {mail.<domain>.org:995/service=pop3/ssl/notls/novalidate-cert} in /home5/<domainname>/public_html/wp-content/plugins/postie/postieIMAP.php on line 78
    Unable to connect. The server said - Can't connect to ghs.googlehosted.com,995: Network is unreachable
    Try putting in your full email address as a userid and try again.

    http://wordpress.org/extend/plugins/postie/

  2. WP Monkey
    Member
    Posted 1 year ago #

    Then I enabled IMAP for that email within Google Apps and got this error message:

    IMAP, Port 143, mailserver = mail.<domain>.org

    Warning: imap_open() [function.imap-open]: Couldn't open stream {mail.<domain>.org:143/service=imap/notls/novalidate-cert} in /home5/<domainname>/public_html/wp-content/plugins/postie/postieIMAP.php on line 78
    Unable to connect. The server said - Can't connect to ghs.googlehosted.com,143: Network is unreachable
    Try putting in your full email address as a userid and try again.

    IMAP, Port 143, mailserver = mail.<domain>.org

    Warning:  imap_open() [function.imap-open]: Couldn't open stream {mail.<domain>.org:993/service=imap/ssl/notls/novalidate-cert} in /home5/<domainname>/public_html/wp-content/plugins/postie/postieIMAP.php on line 78
    The Server said:Can't connect to ghs.googlehosted.com,993: Network is unreachable
  3. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Google needs the following even with Google Apps

    Protocol: IMAP-SSL
    Server: imap.gmail.com
    Port: 993
    Userid: <your full email>

  4. WP Monkey
    Member
    Posted 1 year ago #

    Thanks, that's the one combination that I didn't try, but here is the error message I got with that:

    Warning: imap_open() [function.imap-open]: Couldn't open stream {imap.gmail.com:993/service=imap/ssl/notls/novalidate-cert} in /home5/<domain>/public_html/wp-content/plugins/postie/postieIMAP.php on line 78
    Unable to connect. The server said - Can't connect to gmail-imap.l.google.com,993: Network is unreachable
    Try putting in your full email address as a userid and try again.

  5. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Try pinging gmail-imap.l.google.com from the webserver to ensure that everything is correctly configured. Then try telnet gmail-imap.l.google.com imaps

    If you don't have shell access check with your hoster, some don't allow this.

  6. WP Monkey
    Member
    Posted 1 year ago #

    I'm not sure I understand. The webserver is now Google since I transferred the email MX to google apps, so mail is no longer handled by the web host.

  7. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have your own webserver or are you using a service like hostgator?

  8. WP Monkey
    Member
    Posted 1 year ago #

    Yes, sorry. The website is hosted on Bluehost (which worked before), but we just moved our email services to Google Apps.

  9. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    You need to contact Bluehost tech support and ask them to open up port 993, it is closed by default.

  10. WP Monkey
    Member
    Posted 1 year ago #

    Here is the response from Bluehost:

    Port 993 is the SSL port for IMAP and is open on our end. However, I see that you are hosting your email through Google Apps as stated in the ticket. So, since this is the case, you will not be connecting to them through us, so no settings on our end will affect whether or not you can setup an IMAP connection to Google Apps.

    I was confused about that as well, is we are using Google Apps and our MX for email is all routed through google and their servers, then do I need to try to get them to open up that port?

  11. WP Monkey
    Member
    Posted 1 year ago #

    I double-checked all of the settings and they are at:
    Protocol: IMAP-SSL
    Server: imap.gmail.com
    Port: 993
    Userid: <your full email>

    Plus I went into Google Apps and made sure that the POP and IMAP settings were enabled for the account. Verified the email password, and still I get this error:

    Warning: imap_open() [function.imap-open]: Couldn't open stream {imap.gmail.com:993/service=imap/ssl/notls/novalidate-cert} in /home5/<domain>/public_html/wp-content/plugins/postie/postieIMAP.php on line 78
    Unable to connect. The server said - Can't connect to gmail-imap.l.google.com,993: Network is unreachable
    Try putting in your full email address as a userid and try again.

    So I feel like I'm going in circles.

  12. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    It sure seems that ports 993/995 is being blocked somewhere.

    This post from May seems to indicate that Bluehost is blocking outbound connections.

    http://stackoverflow.com/questions/10695271/connecting-to-gmail-with-php

    If you have any interest in a different hosting company http://devzing.com is my company and although we don't market it we do wordpress hosting for customers who ask.

  13. WP Monkey
    Member
    Posted 1 year ago #

    But we were using Bluehost for over a year and the plugin worked great. Bluehost says that Port 993 is open. The plugin didn't break until we switched to Google Apps, and so now our email is routed through their servers and not Bluehost (which worked before anyway).

  14. WP Monkey
    Member
    Posted 1 year ago #

    You mentioned ports 993/995, so does that mean that 995 needs to be open as well?

    And just for clarification, should I be putting incoming or outgoing information in the mailserver section of Postie?

    And do I need to put the same values in Settings > Writing > Post via e-mail WordPress options or leave that blank?

  15. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    993 is for IMAP with SSL, 995 is for POP with SSL.

    Postie is only reading email from these settings. (incoming)

    Leave the Post via e-mail WordPress settings blank. Postie is a replacement.

    You might clarify with BH support that outbound connections on 993 are allowed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.