WordPress.org

Ready to get started?Download WordPress

Forums

Postie
Postie 1.5.16, 17, 18 do not work for WordPress 3.8 (3 posts)

  1. hshibata_wplog
    Member
    Posted 6 months ago #

    Postie can not handle correctly an email with image attachment file. It always treats the file as empty.
    ---------------------------------------------------
    GetContent: primary= image, secondary = jpeg
    DecodeBase64Part: base64 detected
    GetContent: file name 'hyakuman001.jpeg'
    GetContent: extension 'jpeg'
    GetContent: secondary lookup found image/jpeg
    GetContent: mimetype image/jpeg
    image Attachement: hyakuman001.jpeg
    pre-sanitize name: hyakuman001.jpeg, size:
    post sanitize name: hyakuman001.jpeg
    using post date
    “File is empty. Please upload something more substantial. .........”
    ---------------------------------------------------

    http://wordpress.org/plugins/postie/

  2. petskratt
    Member
    Posted 6 months ago #

    Does not reproduce in my case (Postie 1.5.18, WP 3.8) - tried sending from Gmail, Outlook and smartphone, different JPEGs (edited in Photoshop, straight from Canon camera, some old pic from web), always works.

    Please note, that your debug log has size empty, while mine looks like:

    GetContent: primary= image, secondary = jpeg
    DecodeBase64Part: base64 detected
    GetContent: file name 'triibuline-pets.jpg'
    GetContent: extension 'jpg'
    GetContent: secondary lookup found image/jpeg
    GetContent: mimetype image/jpeg
    image Attachement: triibuline-pets.jpg
    pre-sanitize name: triibuline-pets.jpg, size: 28731
    post sanitize name: triibuline-pets.jpg
    using post date
    postie_handle_upload: detected file type for triibuline-pets.jpg is image/jpeg
    wp_unique_filename: triibuline-pets.jpg
    attachement id: 591
    wp_generate_attachment_metadata
    wp_update_attachment_metadata complete
  3. hshibata_wplog
    Member
    Posted 6 months ago #

    Thank you for your comment.

    It has been resolved by placing .htaccess file in the directory of:

    /public_html/xxxx/wp-content/plugins/postie

    where:

    AddHandler application/x-httpd-phpcgi .php

    is defined. Now the latest version of 1.5.18 is working.

Reply

You must log in to post.

About this Plugin

About this Topic