WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7 Modules
[resolved] post_title hidden field no longer working (38 posts)

  1. 5ivefold
    Member
    Posted 1 year ago #

    I updated contact form 7 and now the post_title field no longer works. Could you please look into this issue. Thanks.

    Contact Form 7 Version 3.3.1
    Contact Form 7 Modules: Hidden Fields Version 1.2.3
    Wordpress 3.4.2

    http://wordpress.org/extend/plugins/contact-form-7-modules/

  2. i3v
    Member
    Posted 1 year ago #

    I've got the same issue on the same config.
    Though, not only [post_title] is not working for me, [post_category], [post_url] and [post_author] are not working too...

  3. lnattes
    Member
    Posted 1 year ago #

    I've the same problem with [post_url].

    Settings:
    I set field like this:
    [hidden hidden-650 "post_url"]

    And The email's message like that:
    URL: [hidden-650]

    Results:
    Html code:
    <input type="hidden" name="hidden-650" value="post_url" class="wpcf7-hidden" />

    And obvious i recive by mail:
    URL: post_url

    Lionel

  4. 5ivefold
    Member
    Posted 1 year ago #

    Ok thanks for posting your issues as well. Hope they get it fixed soon otherwise there is no point in using the plugin.

  5. lnattes
    Member
    Posted 1 year ago #

    you're right. ;O)

  6. i3v
    Member
    Posted 1 year ago #

    Guys,
    do you have problems only with "post_url", or with all other fields as well (like me)?

  7. 5ivefold
    Member
    Posted 1 year ago #

    I went back to version 1.2.2 and it works fine. Version 1.2.3 was giving me issue with all the fields.

  8. i3v
    Member
    Posted 1 year ago #

    Thanks, 5ivefold
    I can confirm 1.2.2 works for me too...

  9. herrschuessler
    Member
    Posted 1 year ago #

    I can confirm post_title not beeing replaced by the actual post_title (at least with CPT) iun 1.2.3.

  10. asisrodriguez
    Member
    Posted 1 year ago #

    please, where can i find the previous version? 1.2.2
    please help.
    thanks
    Asis

  11. i3v
    Member
    Posted 1 year ago #

  12. asisrodriguez
    Member
    Posted 1 year ago #

    terrific¡¡¡¡ many thanks, now, works again.
    Merry Christmas times
    Asis

  13. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    The fix is coming soon in version 1.3. Sorry for the issues.

  14. asisrodriguez
    Member
    Posted 1 year ago #

    Thankiuuuu

  15. i3v
    Member
    Posted 1 year ago #

    Zack Katz,

    Nice to hear that!

  16. Dane Morgan
    Member
    Posted 1 year ago #

    Any idea what kind of frame we are talking about with 'soon'?

  17. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    How about now?

  18. Dane Morgan
    Member
    Posted 1 year ago #

    How about now?

    Now is an awesome time. ;)

  19. 5ivefold
    Member
    Posted 1 year ago #

    Tried v1.3 with wordpress 3.5, contact form 7 v3.3.2 and the hidden fields for page title, URL's etc is not working.

  20. i3v
    Member
    Posted 1 year ago #

    I can confirm v1.3 is also not working with Contact Form 7 3.3.1 & WordPress 3.4.2

  21. i3v
    Member
    Posted 1 year ago #

    PS
    On wordpress 3.5 & Contact Form 7 3.3.2 & Contact Form 7 Modules 1.2.2, when I submit a form, page freezes (those two rotating arrows, /wp-content/plugins/contact-form-7/images/ajax-loader.gif won't go away) though, e-mail is sent OK.

    There's no such behavior on Contact Form 7 Modules 1.3.

    PPS
    Also, [post_url] returns site url, instead of page url on
    (wordpress 3.5 || wordpress 3.4.2)&&
    (Contact Form 7 3.3.2 || Contact Form 7 3.3.1)&&
    (Contact Form 7 Modules 1.2.2)

    So, v1.2.2 is not perfectly working either...

  22. asisrodriguez
    Member
    Posted 1 year ago #

    Sorry but the "new" version not working for me :-(
    ASis

  23. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    In the sent email, the shortcodes should be like this:

    [post_title]
    [post_category]
    [post_url]
    [post_author]

    Not formatted like this:

    [hidden-455]
    [hidden-893]
    [hidden-894]
    [hidden-895]

    Does that fix the issues you all are having?

  24. i3v
    Member
    Posted 1 year ago #

    Thank you, Zack!
    As I've already emailed you, this almost solved the problem. However, [all-fieds] results in some raw code for me, something like
    <dl><dt style='font-size:1.2em;'><font size='3'><strong>your name</strong>:</font></dt><dd style='padding:0 0 .5em 1.5em; margin:0;'>Игорь</dd><dt style='font-size:1.2em;'><font size='3'><strong>your phone</strong>:</font></dt><dd style='padding:0 0 .5em 1.5em; margin:0;'>1234567879</dd><dt style='font-size:1.2em;'><font size='3'><strong>your firm</strong>:</font></dt><dd style='padding:0 0 .5em 1.5em; margin:0;'>IMP</dd>

  25. asisrodriguez
    Member
    Posted 1 year ago #

    yeah yeah yeah¡¡¡¡¡ works perfectly.
    many thanks¡¡¡
    Asis

  26. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    Okay, all these issues are fixed in a new release, version 1.3.1.

    Please start a new thread if you have any issues with the new release!

  27. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    By the way, in the new release, shortcodes can be both like this: [post_title] and like this [hidden-455].

  28. asisrodriguez
    Member
    Posted 1 year ago #

    you are the one Zack¡¡¡

  29. i3v
    Member
    Posted 1 year ago #

    Cool, many thank for the new release!

  30. lnattes
    Member
    Posted 1 year ago #

    Many Thanks Zack, is running find. ;O)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.