WordPress.org

Ready to get started?Download WordPress

Forums

Post won't show up (7 posts)

  1. deliacreates
    Member
    Posted 3 months ago #

    Up to this point I have had no trouble with posts showing up. But today, I scheduled a post and it didn't show up.

    It shows that it has published in my dashboard and I can preview it. I can also search and find it within my site, but it doesn't show up as a new post on my home page or anywhere else. When I google it, it doesn't show up.

    I have checked the date and year. Everything is right. I have copied and pasted the post code into a new post and it still will not work. I am not sure what to do. The only thing I can think of, is that the post was originally a guest post for another blog. Today, I was "bringing the post home" and re-posting the content to my own site. Would that affect things? Any help would be greatly appreciated. Thank you!

  2. WPRanger
    Member
    Posted 3 months ago #

    Are you running a caching plugin? In my experience some such plugins don't clear the cache on a scheduled post.

  3. deliacreates
    Member
    Posted 3 months ago #

    So...I am not very savvy in the technical side of things. I think I am. I see that the W3 Total Cache is activated. How do I remedy the caching issue?

  4. deliacreates
    Member
    Posted 3 months ago #

    Should I click the "purge from cache" link?

  5. WPRanger
    Member
    Posted 3 months ago #

    Normally, when a post is published, the cache should be cleared. Also, it's usual that the cache isn't applied for logged in users. So you may be able to see you missing posts when logged in.

    Manually clearing the cache completely should also allow you to see the posts.

  6. deliacreates
    Member
    Posted 3 months ago #

    Do I clear it by pressing "purge from cache?" Or is there another way to do that?

  7. deliacreates
    Member
    Posted 3 months ago #

    Okay, never mind. I googled how to do it and found out how to empty the cache from the performance dashboard. It worked! Thank you so much for helping me!

Reply

You must log in to post.

About this Topic

Tags

No tags yet.