WordPress.org

Ready to get started?Download WordPress

Forums

Post via e-mail Problem (16 posts)

  1. metras3
    Member
    Posted 4 years ago #

    I am trying to post email to my Word Press blog.
    I have setup the email account and made sure I could email to it and receive email via outlook. Then I removed the account from Outlooks so I wouldn’t interfere while I was setting up Word Press.
    All seems well except I have this problem. When I poll the email account using “wp-mail.pnp” with Word Press I get one of two messages.
    “There doesn’t seem to be any new mail.”
    or
    “Slow down cowboy, no need to check for new mails so often!” ( I understand this message!)
    The emails stay in the INBOX unread.
    I think this might be a simple fix and there is something I missed. Then Instructions are very easy to understand. And I haven’t found anything in the forum yet that makes it work.
    Can you help?
    Marty
    Word Press vers 2.9.2

  2. metras3
    Member
    Posted 4 years ago #

    Update After I did more work on this.
    I have tryed to poll email into Word press from Yahoo, NetZero and a couple of other pop accounts just to see if the problem was the new email account. Well I either get the message that there is non or to wait a while as before.
    This is telling me that the problem is somewhere in WordPress or my or my ISP doing something that isn't letting WordPress get the mail.

    Any Ideas?
    Marty

  3. ajbird
    Member
    Posted 4 years ago #

    I am having the same prob

    2.9.1

    I can see the emails in the mail account wordpress just claims there is nothing there....

    Andy

  4. davidjosephmoody
    Member
    Posted 4 years ago #

    I'm having an oddly similar but not identical problem. I set up a mailing list on my server that only accepts messages from addresses on the list. It sends me an email telling me to review and accept reject or defer if they're not on the list.

    That way, all my users can post directly to the site; cool.

    Problem is, it doesn't work. When I use the wp-mail.php page, it detects the messages and then deletes them. Somewhere in the middle, it forgets to post them to the site . . .

    Anyone have any ideas?

  5. cgreer96
    Member
    Posted 4 years ago #

    I am having this problem as well. Anyone have a solution?

  6. brasstrumpetman
    Member
    Posted 4 years ago #

    Managed to fix this problem by adding a new admin account under the Users tab. Make sure the email address is the same as the one your sending from. Quite a neat security feature to stop unwanted postings.

  7. cgreer96
    Member
    Posted 4 years ago #

    Still not working for me. Created new admin account with the same email address that I have set up on my webhost, but the wp-email.php says that it "appears" there are no posts.

  8. Saildude
    Member
    Posted 4 years ago #

    Have you read this?

    http://codex.wordpress.org/Post_to_your_blog_using_email

    When I set up my site for email I missed the part about adding the line of code in the footer code to call the check for email ( only checks when the site is looked at ). I did have the part of the secret email account set up in "Settings - Writing" - but things would not work without the iframe code.

  9. cgreer96
    Member
    Posted 4 years ago #

    The thing is it doesn't even show the posts in my wordpress admin area, much less on the page where the footer code goes. When I manually check for new posts in the email account it says there are none to be found. However if I go and log in to that email account I can see the posts just sitting there, waiting to be retrieved.

  10. BrentLeavitt
    Member
    Posted 4 years ago #

    Has anyone found a solution to this issue yet? I'm seeing that this is now about three weeks old, I'm wondering if attempts to fix this were abandoned or if there was any further insight.

    I'm experiencing the same issue as cgreer96 and metras3. I've got the email sitting on my server and the wp-mail.php script is not accessing it. At this point, I'm suspecting that there is some sort of block between my hosting account server and the remote email server as they are on different hosts.

    Any other ideas?

    Thanks,
    Brent

  11. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    I tried setting up the post by email..... it worked. Then it didn't.

    Off and on. Finally I gave up, and tried several other solutions before stumbling on one I like.

    posterous.com is what I use.

    I set up with them....I send an email, it gets posted on my wordpress. (and twitter, facebook, flickr...etc if I want)
    Plus I can send pics, media, etc and it gets posted.

    Some people don't like using an outside service.....I'm not picky. I just wanted good functionality

  12. bschirf
    Member
    Posted 4 years ago #

    I too was having this problem, and I think I just solved it.

    The instructions state that we enter the "Mail Server". Thus, I have been entering the name of the server that I enter into my browser when getting in for "Web Mail". E.g.: email.yourdomain.com

    When I did this, the wp-mail.php reports that there are no messages. Thus, I thought I entered the correct server name.

    So, after beating my head against a wall for 2 days (and half a fifth of bourbon) I happened to see instructions that said we should enter "Incoming Server" and I thought that strange.

    I went back into wp-admin, settings, writing... and changed the mail server field to reflect the "Incoming (POP3) Server" value. For GoDaddy, that is: pop.secureserver.net

    BAM! It is now pulling email into WordPress!

    If anyone from WP is listening... please make the instructions more clear! I suspect that a lot of people are making this same rookie mistake!

  13. jtank
    Member
    Posted 4 years ago #

    POTENTIAL SOLUTION FOR US ALL!!!

    I had the same problem as many of you... there is a security feature that says the email you send FROM must be a user of your blog. Else, it dumps it and no post.

    So, for every email account you wish to send posts FROM, create a user account in your admin area. I hope this helps some of you. It did for me.

    Best to you all
    jtank.com

  14. likewinters
    Member
    Posted 4 years ago #

    Yes, I needed to update my server to ssl://pop.gmail.com

    the port # is 995 for them

    I also added the script in the footer from http://codex.wordpress.org/Post_to_your_blog_using_email

  15. justinrosenthal
    Member
    Posted 4 years ago #

    Two separate issues here, both introduced by 2.9.1
    1) wp-mail.php now authenticates the incoming message to check if the sender's address matches a current user's address, and that that user has permission to publish
    a) if not, post status is set to "pending"
    b) if so, post is published
    2) wp-mail.php now includes the lines (at line 23):

    $last_checked = get_transient('mailserver_last_checked');
    //if ( $last_checked )
    	wp_die(__('Slow down cowboy, no need to check for new mails so often!'));

    This code can kill the process to check for mail, preventing your post from being retrieved.

    To check if your problem is (2) above, navigate to http://www.yourdomain.com/wp_mail.php, and see if the words "Slow down cowboy, no need to check for new mails so often!" appear. If they do, that's your problem. Only solution I have found is to comment out these lines.

  16. petrusfajarsubekti
    Member
    Posted 4 years ago #

    Hmmm... I never know that we can post by email.

    Why that "slow down cowboy..." trouble the system?
    Does WP didn't debug this?
    I will try this thing on my blog

Topic Closed

This topic has been closed to new replies.

About this Topic