WordPress.org

Ready to get started?Download WordPress

Forums

Post too long won't display or preview (6 posts)

  1. marc.cizravi
    Member
    Posted 5 years ago #

    I'm having an issue where a post of mine get's past 3,500 (approx.) words and stops displaying. I'll delete a small chunk of the post (in the beginning or middle or end) and it'll preview and post fine.. but if it's too long it bugs it and show a blank page (title, and comments but no content...)

    Anyone help?

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    A link to your site would help.

  3. Denis Kuznetsov
    Member
    Posted 5 years ago #

    add at the top of wp-config.php following code:

    ini_set("pcre.backtrack_limit", 10000000);

  4. knion
    Member
    Posted 5 years ago #

    same issue here.. i tried ini_set("pcre.backtrack_limit", 10000000); .. and it doesn't work. Other solutions ?

  5. morganfletcher
    Member
    Posted 5 years ago #

    FWIW I had a similar problem. I upgraded from php4 to php5, and then a large post on my blog wouldn't display. I tried messing with memory, cpu and timeout settings, but nothing made it change. Then I found this page and made this change in my php.ini:

    < ;pcre.backtrack_limit=100000
    ---
    > pcre.backtrack_limit=1000000

    Restarted apache2 and now the post displays.

    FWIW,

    Morgan

  6. freelanceunbound
    Member
    Posted 4 years ago #

    I had this problem with a post that had a lot of embedded video content. It seems to be that WordPress prefers to break long content over more than one page.

    SO - you need to use the <!--nextpage--> code to split your post into manageable chunks (see Codex).

    In the HTML view, just add <!--nextpage--> at the cursor wherever it works best for a page break. Simple and worked for me...

    There's a discussion about this here too.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.