WordPress.org

Ready to get started?Download WordPress

Forums

post title error? (6 posts)

  1. willrabbit
    Member
    Posted 3 years ago #

    Loving the theme so far, just one weird error - under the post title there is an extra line with a code fragment.

    it looks like this:

    Post Title
    width="290" height="290">

    rest of post ....

    I cannot seem to find where this width and height are coming from.
    Plus, it is not affecting all of the posts titles.
    It mainly seems to happen to the left-most post in each row of the grid?

    Thanks for any help in clearing this up.

  2. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    Let me guess, you're using Tanzaku theme? <div class="grid-image">. In index.php you will find:

    <h2 class="post-title">
    <a href="<?php the_permalink() ?>" rel="bookmark"><?php the_title(); ?></a></h2>

    move this after:

    <?php if ($grid_img) echo '<div class="grid-image">' . $grid_img . '</div>'; ?>
    <div class="post-body">

    This should be it,
    Emil

  3. willrabbit
    Member
    Posted 3 years ago #

    thank you for the suggestion Emil.

    (oops, i guess i forgot to mention that i am using the tanzaku theme.)

    i moved the post-title section after the grid-image section
    and now the code fragment of
    width="290" height="290">
    is showing at the top of the post area

    i believe something in this grid-image is the culprit, since i tried commenting that line out and the code fragment disappeared.
    unfortunately my images & video also disappeared, so not a permanent fix.

    my guess is some minor bit is missing that makes this show up, but i cannot seem to follow the spaghetti code trail of the php to figure it out yet.

    any other ideas on how to fix this up?

  4. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    I guess is that similar was answered here, can you try this:

    If you are in the main "page", the php will be the index. If you are in a category called "my top music" (for example) and you've created a php called category-my-top-music, that will be the php used for that category.

    the tazaku index file goes this way:
    -header
    -single-wrapper
    -comments_template
    -grid-wrapper
    -footer

    Which means if you are on a single post the code corresponding will be "single-wrapper" and if you are in the "main page" where more than one post is shown you will be in the "grid-wrapper".
    Please tell what is your case and a link, maybe I can help (as I had the same problem before).

  5. willrabbit
    Member
    Posted 3 years ago #

    I reinstalled tanzaku theme and so far the error has not returned.
    I had not done much tweaking to the code, so not sure what happened.
    I will update if the problem returns.
    Thanks Emil for trying to help fix this :)

  6. Emil Uzelac
    Theme Review Admin
    Posted 3 years ago #

    No problem :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags