WordPress.org

Ready to get started?Download WordPress

Forums

Email Encoder Bundle - Protect Email Address
[resolved] Post tag seen as shortcode and breaks feed (4 posts)

  1. Michael
    Member
    Posted 6 months ago #

    I think one of the sites in our network encountered a bug with the new 1.0.0 feature "Added option removing shortcodes for RSS feed."

    Today I deployed the 1.0.1 version of Email Encoder Bundle, upgrading from 0.80, and their site feed stopped working.

    This author had tagged one of her posts with the word "video." In the RSS feed, WordPress normally wrote the tag like the following:
    <category><![CDATA[video]]></category>

    When the Email Encoder Plugin is active, the feed displays an error message, and the same tag looks like the following:
    <category><![CDATA]></category>

    I use Google Chrome for testing my feeds, and the error message reads:
    This page contains the following errors:
    error on line 165 at column 13: internal error
    Below is a rendering of the page up to the first error.

    The same problem occurred when I tagged a post with "video games" or "video player." It did not occur when I tagged the post with "videos."

    When I deactivate the Email Encoder plugin the feed works again.

    Is it possible that the shortcode removal feature is not compatible with the way that WordPress writes tags in its feeds?

    http://wordpress.org/plugins/email-encoder-bundle/

  2. freelancephp
    Member
    Plugin Author

    Posted 6 months ago #

    <![CDATA[video]]>
    Probably the WordPress shortcode filter acts like [video] is a shortcode, but in this case it's not.

    In your case I recommend to disable the option.
    Only disabling the option does not work, I have to fix that first.

  3. freelancephp
    Member
    Plugin Author

    Posted 6 months ago #

    Setting the option should be fixed in version 1.0.2.

  4. Michael
    Member
    Posted 6 months ago #

    I upgraded to 1.0.2, and disabling the shortcode option will be good workaround. Thank you for the fix.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.