WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
post-sitemap.xml and other sitemap files doesn't get cached (4 posts)

  1. niska
    Member
    Posted 1 year ago #

    I updated to w3 total cache 0.9.2.6 and now I'm unable to get caching of xml files to work. Checking the footer of post-sitemap.xml (generated by the yoast seo plugin) say:

    <!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/
    
    Minified using disk: basic
    Page Caching using disk: enhanced
    
     Served from: www.domain.com @ 2013-02-05 10:25:30 by W3 Total Cache -->

    But when reloading the page (I'm not logged in) I get a new timestamp.

    What could be wrong?

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    This is probably due to WP is_feed() check that is used in the plugin. You will need to enable cache feeds on the page cache settings page inorder to cache site maps. xml files are interpreted to be feeds.

  3. niska
    Member
    Posted 1 year ago #

    I've already enabled "Cache feeds: site, categories, tags, comments". Do I need to do something more?

    I've checked the cache/page_enhanced folder and I'm unable to find any post-sitemap-files. The "feed" folder is there, so it is cached as expected.

  4. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Can you submit a bug report from the support tab of the plugin because I cannot reproduce using WordPress SEO, latest plugin version with page caching disc enhanced and cache feeds enabled.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.