WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Post Shows (No Title) But Has Title On Opening (3 posts)

  1. WebTechGlobal
    Member
    Posted 4 years ago #

    Strange one, in short it appears that my post has two different states.

    To be clear I'm the developer of CSV 2 POST and Easy CSV Importer, they make pages using data. I only use wp_insert_page and wp_update_page.

    I'm guessing that I'm doing something wrong but then I think how can I be. The post shows (no title) on...

    http://localhost/testing/csv-2-post-dev/wp-admin/edit.php

    Then when clicking edit on that post the title holds...

    Hotel Louis Phaethon beach

    I clicked update and on the edit.php page, still says (no title).

    So overall the question is, why would a post in the admin show two different states?

    Also there is content but on opening the post to view it in the blog, the page does open but theres no content. No title or main content, comment form shows that is it.

    Strange one. Suggests would be welcome because my whole application of 2 months work rests on this.

    Ryan

  2. WebTechGlobal
    Member
    Posted 4 years ago #

    When I add more posts, the last post always shows ( no title ) and the title suddenly appear for others however the actual page is still blank.

  3. WebTechGlobal
    Member
    Posted 4 years ago #

    Sorry folks this is fixed, I was causing it somewhere in my code, can't say where and how it is top secret lol

    Basically intercepting the posts loop and editing $posts but some sort of variable miscount was skipping first record.

Topic Closed

This topic has been closed to new replies.

About this Topic