WordPress.org

Ready to get started?Download WordPress

Forums

Post scheduling still not working (17 posts)

  1. Hakkim P Ahammed
    Member
    Posted 2 years ago #

    Hi,
    This is very unfortunate to see that this critical issue is still found unfixed.I don't understand why WordPress guys not giving much importance to this.For me, am using two important newspaper sites in WP and this functionality is very crucial for me.I hope you can fix this soon.Currently am using WP Missed Schedule plugin, this can fix this issue up to an extend.I am expecting a quick reply from WP regarding this.

    Thank you,
    Hakkim.

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    It's not fixed because it is working for the vast majority of WordPress users. This problem is specific to your site.

  3. Hakkim P Ahammed
    Member
    Posted 2 years ago #

    Hi Esmy,
    Thanks for your reply.
    But I don't think this is specific for me.I have searched a lot regarding this issue for the last couple of months, and I can found a lot of peoples having the same issue.But still could not found any solution from within the WordPress itself.I wonder why WordPress didn't fix this.

    Also I confused with your comment 'It's not fixed because it is working for the vast majority of WordPress users',STILL NOT FIXED,then how will it work for other WordPress users???

    Thanks,
    Hakkim

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    WordPress currently has something in the region of 12 million users. How many posts have you seen on this subject? Ten? Twenty? These are all site-specific issues. I schedule posts regularly on some of my WP sites and they are published just fine.

  5. Hakkim P Ahammed
    Member
    Posted 2 years ago #

    Hi Esmi,

    Ohh that's good, but have you used any plugins OR have you set crone jobs via cPanel? Or you are saying default WP post scheduling works for you? I am just asking :)

    Thanks,
    Hakkim.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    The default WP post scheduling works for me and (apparently) for millions of other WordPress users.

  7. Hakkim P Ahammed
    Member
    Posted 2 years ago #

    OK, but I am a bit confused and still could not found where I went wrong :( , this is not working for my two newspaper sites and I managed it with WP Missed Schedule plugin.Do you have any idea about the facts that may affect this default functionality? so that I can check for that.
    Thanks.

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  9. Hakkim P Ahammed
    Member
    Posted 2 years ago #

    Really thanks esmi, let me try it.

  10. sLa NGjI's
    Member
    Posted 2 years ago #

    This problem, is not related to my plugin WP Missed Schedule.
    The question is general, and not specific to my plugin WP Missed Schedule.
    My plugin, WP Missed Schedule, work fine without problem!
    Now, "This topic is not resolved" label is not correct!
    Change it to: "This topic is not a support question" A.S.A.P.

    Thanks!

    This general problem is simple: due to wp-cron.php changes, since WordPress 2.6.x, the future scheduled posts failed! All others are only suppositions ...

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    :lol :lol :lol

  11. sLa NGjI's
    Member
    Posted 2 years ago #

    WordPress currently has something in the region of 12 million users. How many posts have you seen on this subject? Ten? Twenty? These are all site-specific issues. I schedule posts regularly on some of my WP sites and they are published just fine.

    It's not fixed because it is working for the vast majority of WordPress users. This problem is specific to your site.

    Google results:

    1 - WordPress Failed Future Posts - About 25,300,000
    2 - WordPress Missed Scheduled - About 4,900,000
    3 - WordPress wp-cron scheduled posts - About 4,680,000

    The default WP post scheduling works for me and (apparently) for millions of other WordPress users.

    "apparently" or really worrk?

    Prevents missing scheduled posts in WP-Cron

  12. Hakkim P Ahammed
    Member
    Posted 2 years ago #

    Hi sLaNGjI,

    I think, this issue is not fixed yet, I didn't said its your plugin's issue.I posted this thread to know why WordPress could not find a solution for this issue from WP itself.Currently I am using your plugin to manage scheduled posts and it works fine for me except some delay in publishing time(I know why it happens). We can fix this also by setting crone jobs via cPanel/Plesk.I have two newspaper websites that running in WP, so post scheduling is very important for me.

  13. sLa NGjI's
    Member
    Posted 2 years ago #

    Hakkim change "This topic is not resolved" label to "This topic is not a support question" A.S.A.P. Please!

    We can fix this also by setting crone jobs via cPanel/Plesk

    No! This problem is related to WordPress wp-cron.php only. All others action are irrelevant.

    I am using your plugin to manage scheduled posts and it works fine for me except some delay in publishing time(I know why it happens).

    Explain more details ...

  14. Hakkim P Ahammed
    Member
    Posted 2 years ago #

    Hi sLaNGjI,

    [No! This problem is related to WordPress wp-cron.php only. All others action are irrelevant.]
    >>>>>>>>>>>>>>>>
    can you please try this,

    1.Set a crone job via your cPanel/Plesk to run wp-cron.php file in every minute,every hours,every day, every week,every month, every year.

    2.Please add this php code 'define('ALTERNATE_WP_CRON', true);' in your wp-config.php just above to the comment saying 'That's all, stop editing! Happy blogging.'

    3.If you have used any plugin to manage this issue (like WP Missed Schedule), please deactivate it.

    4.Then, please schedule a post to see it is working.

    [Explain more details ...]
    >>>>>>>>>>>> What I meant is it (your plugin) will check for the 'Missed schedule' posts in every 5 minutes, right?. So in some cases it may causes a delay(around 5 mins) in publishing the post than the actual time of publishing. Please ignore it. I just mentioned this, that's all :)

  15. sLa NGjI's
    Member
    Posted 2 years ago #

    I have pleasure of this technical discussion with Hakkim.

    1.Set a crone job via your cPanel/Plesk to run wp-cron.php file in every minute,every hours,every day, every week,every month, every year.

    2.Please add this php code 'define('ALTERNATE_WP_CRON', true);' in your wp-config.php just above to the comment saying 'That's all, stop editing! Happy blogging.'

    3.If you have used any plugin to manage this issue (like WP Missed Schedule), please deactivate it.

    4.Then, please schedule a post to see it is working.

    This is correct, but is a workaround (same as plugin work). The discussion problem is related to wp-cron.php bug, on WordPress Core, since build 2.6.x ...

    Your plugin will check for the 'Missed schedule' posts in every 5 minutes. So in some cases it may causes a delay, around 5 mins, in publishing the post than the actual time of publishing.

    Correct!

    You have a technical solution?
    You have a portion of code, to insert on my plugin, to solve this delay issue?

    ;)

  16. Hakkim P Ahammed
    Member
    Posted 2 years ago #

    [This is correct, but is a workaround (same as plugin work). The discussion problem is related to wp-cron.php bug, on WordPress Core, since build 2.6.x ...]
    >>>>>Yes, that is why am asking, why WP could not fix the bug with wp-cron.php still? :)

    [You have a technical solution?
    You have a portion of code, to insert on my plugin, to solve this delay issue?]
    >>>>> I need to have a detailed look on your plugin code, let me check that :)

  17. dconnors
    Member
    Posted 1 year ago #

    I have definitely traced my problem with posting not working to JetPack!!!!!

Topic Closed

This topic has been closed to new replies.

About this Topic