WordPress.org

Ready to get started?Download WordPress

Forums

Post Save or Publish Times Out (37 posts)

  1. Lorelle
    Member
    Posted 9 years ago #

    Maybe it is a problem with my host server, and maybe this isn't something that can be handled within the WordPress "engine", but I'm almost always timing out (returns a page 404 not found) when I hit the save or publish on most of my long posts, especially those with html in them. Long posts specifically, not short ones. I've had the same problem with 1.2 and 1.5.

    When the SAVE or PUBLISH is clicked, I believe WordPress goes through and cleans things up, so maybe this is where the time out to a 404 occurs. Ideas?

  2. NuclearMoose
    Member
    Posted 9 years ago #

    Are you doing track/pingbacks in the articles where this is happening? They can significantly slow down the posting process as WordPress will attempt to contact all of those sites to inform them of the track/pingback.

  3. Lorelle
    Member
    Posted 9 years ago #

    Hmm, I thought I had them turned off cuz this is seriously under development. Any way of doing a batch or mass turn on and off of the pings and trackbacks?

    Anyone else having this problem?

  4. amused
    Member
    Posted 9 years ago #

    It's outgoing pingbacks and trackbacks that would slow you down, not incoming. There doesn't seem to be an option to turn this off in 1.5 though. Maybe there should be a bug for that.

  5. Lorelle
    Member
    Posted 9 years ago #

    It's really critical when developing a site, though I'm not sure if you'd want to turn it off when actually running a site. These time outs are time wasters for me. I have to reload the page every time it stalls, and it takes a long time to actually give me the 404 error so I know it's not going to go back to the Manage screen or whatever.

  6. chuckblue
    Member
    Posted 9 years ago #

    Maybe you could type the long posts offline in an ascii text editor.

    Log into admin in wp.

    And then copy and paste them into the edit window in wp.

    I found several ascii text editors by going to http://download.com and searching for:

    ascii text editor

    I use the pfe and edit pad lite editors.

  7. Lorelle
    Member
    Posted 9 years ago #

    I write my new posts in WordPerfect, spell check them, and post them. But what I'm having the time-outs on is stuff I'm moving from my html files. I am not going to strip every html code out of these documents since I don't need to.

    And it seems that the problem isn't with the code fixers but the pings and trackbacks....I'd really like to turn them off globaly until I'm ready for them.

  8. James
    Happiness Engineer
    Posted 9 years ago #

    Uncheck "PingBack the URIs in this post", below the post field.

  9. Lorelle
    Member
    Posted 9 years ago #

    Right. On several hundred individual posts that I'm editing. That's the problem. I have to check them off as I save the editing changes, and then when I'm done (which feels like forever at this rate) with all the changes, I will have to go through either WP or MySQL and change all these back to on.

    That's why it would be nice to have a global on/off switch, or a way of commenting out the feed from the index.php or something temporary but easy.

  10. James
    Happiness Engineer
    Posted 9 years ago #

    To disable trackbacks/pingbacks entirely, delete wp-trackbacks.php, but that has no effect on how long it takes to post. Unchecking "PingBack the URIs in this post" does.

  11. Lorelle
    Member
    Posted 9 years ago #

    thanks for the info on the trackbacks. I'll rename the file for now and see if that changes the timing a little bit.

  12. Lorelle
    Member
    Posted 9 years ago #

    Okay, I've started unchecking the pingbacks and I renamed the wp-trackbacks.php file, and I'm still having time outs. Even on posts that aren't "that" long. The "fix invalid XHTML" is also turned off.

    Maybe it's my connection, but this is a top speed cable broadband and other things go whip snarl fast.

    What else could be generating to slow things down?

  13. James
    Happiness Engineer
    Posted 9 years ago #

    It could be a problem on your server's end. How is everything else? Like changing the index.php template or adding a link for example.

  14. Lorelle
    Member
    Posted 9 years ago #

    Speed demon for updating index.php and other things. Only on the post when editing. The info is already in the database, I'm just editing it and hitting save. It can take up to 2 minutes now. Even on the smaller posts.

    I wonder if there is a plugin that is slowing things down.

  15. NuclearMoose
    Member
    Posted 9 years ago #

    Disable all of your plugins, Lorelle, and then check the speed. Then enable them one at a time, recheck, and then enable another. Please let us know if you find anything! :)

  16. Lorelle
    Member
    Posted 9 years ago #

    I "think" I've found the culprit - after much messing around with the plugins. Related posts by Alexander Malov & Mike Lu seems to be the culprit. I'll post a note on the site letting them know. Ugh, this is one of my favorite plugins!

  17. nsxpower
    Member
    Posted 9 years ago #

    Thanks for your comment Lorelle (I am not a regular on WP forums anymore ... no time). I will install WP 1.5 and try t replicate your problems, although at this time I don't see how my plugin could be the culprit. If anyone has any ideas please share.

  18. Lorelle
    Member
    Posted 9 years ago #

    NOPE. I have EVERY plugin now deactivated - including the spam killers, and it still is timing out....back to square three? And sorry for issuing blame where none should have been. This timing out thing is becoming semi random. It works fine and then times out over and over againg. It was when I had the related posts deactivated that it worked fine for about 5 post edits, and then back to time outs. I turned it back on and it timed out for two times, and then worked fine for 3 times and now we are back to three minutes to store the page...with the occassional time out.

    If it ain't WordPress or the plugins, it has to be the interaction of WordPress and the server's MySQL. From here, I'm lost to figure out how to check this. MySQL and PHP are up-to-date and met WordPress requirements.

    Is anyone having time out or long waits when posting their WordPress stuff? Especially on long posts?

  19. Anonymous
    Member
    Posted 9 years ago #

    Even if mySQL is up to date, that won't prevent slow connections, particularly at times of heavy traffic. Have you tried posting at times when the server is less busy?

  20. James
    Happiness Engineer
    Posted 9 years ago #

    What is your MySQL version?

  21. nsxpower
    Member
    Posted 9 years ago #

    Ok, try to comment out like 133 (starts with "add action ...") and see if that improves performance. That line tells the plugin to go through your post to find keywords on edit_post.

  22. Lorelle
    Member
    Posted 9 years ago #

    I have been working at odd hours and not consistently cuz I've on the road traveling right now, so it is hit and miss for the past few weeks. I've also been working with three different computers in three different states and Internet services, and the problem has been consistent all the way across those. So finding a time when the server isn't busy...how would I know?

    It was working really great for about an hour today and then started dragging again. Hit and miss.

    MySQL is mysql Ver 12.22 Distrib 4.0.18.

    nsxpower: And where will I find line 133? In the index.php? And comment out how much do I comment out? Oh, in the plugin? So the plugin lines up the keywords on the edit post save...hmmm. I'll give it a try. Thanks.

  23. Lorelle
    Member
    Posted 9 years ago #

    nsxpower:

    commented out the line and nothing has changed. So you all aren't the culprit for this.

    ==========
    Is anyone else having time out troubles or really, really long saves of their posts?

  24. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I have long times to publish only when I link to non-pinging sites, such as the BBC. No links, quick. Other blogs, pretty damn quick.

  25. Lorelle
    Member
    Posted 9 years ago #

    I have another clue: on SAVE, it processes speed of light. It is only on the PUBLISH the three, four minute wait appears.

    I've turned off the pings, trackbacks, played with turning plugins on and off, and still it takes forever. I have a lot of html, so to speak, in these posts, but what could possibly be churning and causing the delay? If SAVE goes rocket fast, why wouldn't PUBLISH? What's the difference?

    I did a check and a sample post that is still whirling and clicking from me hitting PUBLISH even as I write this...nope, checked and still "loading"...was actually smaller than most of them with:

    characters: 7323
    words: 1456
    lines: 112
    pages (letter size equiv): 3

    This problem may be unique to me, but maybe not, which is why I'm so dogged about it.

  26. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    Lorelle, it honestly sounds like your host is just getting overloaded. If the server is too busy things will randomly slow down without rhyme or reason like you describe.

  27. TechGnome
    Moderator
    Posted 9 years ago #

    In your writing options area in the admin.... check to see what Update Services are being pinged..... I know I had issues until I turned this off.

    Tg

  28. Lorelle
    Member
    Posted 9 years ago #

    Everything turned off. Dramatically and drastically off. I've a list of what I did so I can fix it later. I hope.

    But there is some relief for my poor bottom sitting and waiting and watching the whirl and click of "loading". I have finally, after two months of struggle, figured out how to upload this endless line of babble I've created by conversion to the MT format and using the import-mt.php to get it slapped into the database. I'll whine again when I have to edit each of these during the check and test process, but for now, at least the stuff is getting in high speed.

    Thanks!

  29. WebSP
    Member
    Posted 8 years ago #

    Lorelle, can you explain what you have changed? I also have similar problems with long posts and the Publish button!

  30. WebSP
    Member
    Posted 8 years ago #

    I'm sorry to go and post here again, but I am in need of any help that you can provide me.

    Thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.