WordPress.org

Ready to get started?Download WordPress

Forums

Post Preview not Working (32 posts)

  1. Emory
    Member
    Posted 5 years ago #

    When clicking the preview button from within a post, I am taken back to my site's home page (http://www.mysiteislocatedhere.com/) instead of seeing the page I want to preview. This has been occurring with previous versions up until now with 2.7. I haven't found a solution on the forums. Please post if you know how to fix this.

    In General settings:
    WordPress address http://www.mysiteislocatedhere.com/sub
    Blog address http://www.mysiteislocatedhere.com/

  2. uptempoair
    Member
    Posted 5 years ago #

    Wondering if anyone has a fix for this? I am having same issues...

    I post preview and it takes me to my homplage of the blogs.

  3. TheFitnessNerd
    Member
    Posted 5 years ago #

    2.7.1 upgrade is supposed to solve this issue. It appears to be caused by a caching problem.

    Here's a fix to try in the meantime: clear your cookies and cache in your browser. Close all browsers, reopen it and try logging back into your WP Admin. Should solve the issue. Did for me.

  4. mdfrancois
    Member
    Posted 5 years ago #

    This doesn't fix anything, and 2.7.1 hasn't fixed it either.

    Blog URL is: http://carinabro.mdf.net
    Wordpress URL is http://mdf.net/wp

    Eveyything works, except preview. Checked on multiple browers/platforms/computers. Deactivated all plugins.

    just doesn't work.

  5. Jeremy
    Member
    Posted 5 years ago #

    I'm having the same problem since 2.7, and still with 2.7.1. I get a 404 page. This is happening on two entirely different domains.

  6. noise
    Member
    Posted 5 years ago #

    same issue here - although not with a new install of wp with a fresh database.

    Must be an updating issue

  7. Emory
    Member
    Posted 5 years ago #

    Appears to work for me in 2.71.

  8. steeephen
    Member
    Posted 5 years ago #

    Same issue here at blog.worcestershirewebdesign.co.uk - only ever used 2.7.1, all ok until yesterday but now cannot preview anything, keeps saying "Sorry, no posts matched your criteria."

    have tested in firefox, chrome and safari and same problem in all even after clearing cookies/cache.

    the problem does not appear in IE7.

    any ideas?

  9. steeephen
    Member
    Posted 5 years ago #

    I've found the answer at http://www.leateds.com/2008/theme-preview-for-wordpress/

    I had my blog at "mysite.com/blog" and had a subdomain of "blog.mysite.com" but I've changed the wordpress general settings so that the url is the same for both and a 301 redirect should get my subdomain working ok.

    preview is now working in all browsers.

  10. upnsadmin
    Member
    Posted 5 years ago #

    Thanks steeephen for the update. I'm also experiencing the same problem. I attempted to change .htaccess and managed to make a mess of things. Everything is now back to normal to my relief. As I'm not an expert with .htaccess, could you pls tell me what I need to code up for this. Much appreciate.

  11. Guppy411
    Member
    Posted 5 years ago #

    I have the same problem, started with 2.6 upgrade. I thought it was .htaccess issue as well so I set my permalinks to the default and still no success in IE8 or Firefox 3.

    I see strings going back to 2.5 with not a single solution.

  12. tndleffel
    Member
    Posted 5 years ago #

    For me it was a mismatch in the WordPress address and blog address. Once I made them the same (removing the www from one of them), the preview suddenly worked like it was supposed to. Yea!

  13. Emory
    Member
    Posted 5 years ago #

    I take it back... Still not working for me in 2.7.1

  14. Joao Faraco
    Member
    Posted 5 years ago #

    I'm getting this since I upgraded to 2.8.1

  15. imaginethepoet
    Member
    Posted 5 years ago #

    I am getting the same issue in 2.8.4. This was not happening in 2.8.1

    Ideas?

  16. Matt Rude
    Member
    Posted 5 years ago #

    Try disabling and re-enabling Google Gears in your web browser and see if this is still happening.

  17. Art Gatenby
    Member
    Posted 5 years ago #

    I have the same problem. I click on Preview and I go to theme page and the 404 error. I'm now at 2.8.4. Gears is not running

  18. Art Gatenby
    Member
    Posted 5 years ago #

    The Other error is Sorry, no posts matched your criteria.

  19. littlesin
    Member
    Posted 5 years ago #

    I'm having the same problem in 2.8.4 with the error Sorry, no posts matched your criteria. I think it has to do with firefox, as I can preview just fine in IE8.

    Anyone have any suggestions?

  20. CallUp
    Member
    Posted 5 years ago #

    I'm having the same problem in 2.8.4. WordPress address and blog address are the same. Hmmm ...

  21. mrtsherman
    Member
    Posted 5 years ago #

    Same problem. There must be a solution other than having to mess with .htaccess. Yargh!

  22. sprezzaturon
    Member
    Posted 4 years ago #

    I've had this "no posts matched..." preview problem since 2.7. Today's upgraded puts me at 2.8.4 and still no fix. I have yet to this resolved. I have to say WordPress is very disappointing....

  23. imaginethepoet
    Member
    Posted 4 years ago #

    Anyone has a solution to this? I would love to be able to preview posts again. It went haywire after the upgrade. Also no offense, but these are these least helpfull forums on the net. I have no problem responding to people in forums, but here it's just hard to get a response from anyone about any topic.

    You would think an open community would be more open.. - Rant mode off.

  24. Lweel8
    Member
    Posted 4 years ago #

    I fixed mine by changing my Permalinks structure, saving, and then putting it back and saving again. I'm assuming it edited the .htaccess file in the background and has made it readable again. Didn't have to edited it myself, which is a huge relief.

  25. microbiz
    Member
    Posted 4 years ago #

    Are there any other options for fixing this? Changing permalinks did not help. I onlyhave this problem with IE. I can preview if I use Firefox or Chrome, just not IE.

  26. nihonsei
    Member
    Posted 4 years ago #

    I faced this problem in WordPress 2.8.6 and solved it by following these steps:

    1. Create a blank .htaccess file in Blog folder.
    2. Go to Settings-> Permalinks
    3. Select a common setting.
    4. Save Changes.
    5. Copy all code from Permallinks (code showing at the bottom of Permallinks screen) and past in .htaccess file.
    6. save you .htaccess file.
    7. Change this .htaccess file with 777 full write permission. (This step is very important)
    8. Repeat once again Step 2, step 3, step 4. (You may not need to follow step 8 (Optional))
    9. Post a new or Edit your old post
    10. Confirm your Preview Changes by clicking it.

    If you are still facing this problem, please copy code for .htaccess file from Permallinks and paste it to .htaccess file in WordPress core file folder. Give full write permission (777). Try preview (Step 9 and Step 10)
    I hope it will work fine.

    If everything is allright, please change .htaccess file permission 705 or 604 for your web security.

    Good luck!

    Nihonsei

  27. nihonsei
    Member
    Posted 4 years ago #

    Please enter "ftp user name" and "path" into index.php in blog folder.

    index.php
    /** Loads the WordPress Environment and Template */
    require('/home/ftp-username/public_html/path/wp-blog-header.php');

  28. LiseyMac
    Member
    Posted 4 years ago #

    Another possibility (I'm using 2.8.6): try a different browser.

    Having never had one problem with WordPress until today, I suddenly found my preview post button not working. After trying everything from file permissions to resetting my Permalinks to disabling plugins to changing my theme, I thought back to the only major thing I had changed in the last 24 hours. My browser.

    For whatever reasons, Google Chrome for Mac is giving me the "no matching entries found" error. Logged in with Firefox, and preview is working just fine. Go figure.

  29. agroguru
    Member
    Posted 4 years ago #

    I fixed the problem on my blog. In the settings general, be sure the WordPress address (URL) and the Blog address (URL) match.

  30. Valerie Hecht
    Member
    Posted 4 years ago #

    Thank you agroguru! That worked! I've been dealing with that frustration for a couple of upgrades and almost stopped blogging. I'd have had no idea it was such an easy, elegant fix.

Topic Closed

This topic has been closed to new replies.

About this Topic