WordPress.org

Ready to get started?Download WordPress

Forums

Post preview is not working! (4 posts)

  1. marenaza
    Member
    Posted 6 years ago #

    I can publish a post, but I can't preview while I am writing. What I see when I use the preview button is my blog, and in the place of the new post, the message "Not Found
    Sorry, but you are looking for something that isn't here."

    I think that must be a problem with the .htaccess file.
    I have the wordpress installation in:
    http://solaiz.com/aldares.com/wordpress
    When in options of my blog, I set :
    WordPress address(URL):http://solaiz.com/aldares.com/Wordpress
    Blog address (URL):Blog address (URL):http://solaiz.com/aldares.com/Wordpress
    the preview works fine.
    But when I change the Blog address (URL)to http://www.aldares.com (that is a domain that is pointing to http://solaiz.com/aldares.com/Wordpress) then the preview (while I am writing) show the error message: Not Found
    Sorry, but you are looking for something that isn't here.
    What I have in my .htaccess file is:

    RewriteEngine on
    Options +FollowSymlinks
    RewriteBase /
    RewriteCond %{HTTP_HOST} /aldares.com/WordPress/
    RewriteCond %{REQUEST_URI} !/aldares.com/WordPress/
    RewriteRule ^(.*)$ aldares.com/WordPress/$1 [L]

    Someone can see something wrong?
    Thank you in advance!

  2. scottystang
    Member
    Posted 6 years ago #

    I also have a similar issue after upgrading from WP 2.0.4 to WP 2.3.3. I created my own theme and post preview doesn't work. When I click the preview link after saving a post, I am brought to the home page and not the post preview. However, if I change my theme to the default, post preview works.

    It looks like the issues is with my theme. Any ideas on where/what to check first?

  3. StrangeAttractor
    Member
    Posted 6 years ago #

    In response to ScottyStang:

    They did away with the Preview Frame in versions after 2.1 (IMHO they should have kept it, or at least made it optional).

    You can restore this function with the Preview Frame plugin.

    However, I don't know why your Preview link is not leading to the right page.

  4. noise
    Member
    Posted 6 years ago #

    Still not working in 2.6

Topic Closed

This topic has been closed to new replies.

About this Topic