WordPress.org

Ready to get started?Download WordPress

Forums

Posts in Sidebar
[resolved] Post not showing on frontpage (10 posts)

  1. pboleo
    Member
    Posted 8 months ago #

    I have recently installed version 1.14 of Posts in Sidebar (amazing work, btw), and i have it configured to show 1 random post from a specific category.

    The problem is that the frontpage of the site always says "no posts yet.", although if you navigate throughout the site, it will randomly show posts from that category.

    The site is http://acoolnet.com and the widget is located at the right sidebar, under the title "Mensagem da Equipa" (Team Message)

    Thanks in advance for all your help.

    http://wordpress.org/plugins/posts-in-sidebar/

  2. aldolat
    Member
    Plugin Author

    Posted 8 months ago #

    I see that the plugin works correctly in your site but only in the home it displays "No posts yet". This could be an issue related to the current theme (or anything else).

    1. Make a screenshot of the current widget options and post here the link to it.

    2. Could you temporarily turn off the "Artigos Recentes" section? If so, please turn it off, see if the list appears in home page and tell me here the answer (then you can reactivate the "Artigos Recentes" section").

  3. pboleo
    Member
    Posted 8 months ago #

    Hi aldolat!. Thank you so much for your fast reply.

    Here is the link for the widget options.

    I deactivated the "Artigos Recentes" (Recent Articles) section and changed it for a static page, but the problem persisted and still only on frontpage (all other pages worked correctly).

    I also installed another theme (twenty thirteen) to see if that's where the problem was, but the situation persisted (no post on frontpage), and posts on every other page.

  4. aldolat
    Member
    Plugin Author

    Posted 8 months ago #

    Hi,
    I just tried with different themes and different homepage options (a static page as home or latest posts) - everything works fine.

    Could you make a try in a localhost environment? Install only the current theme you are using on your live site and install only the "Posts in Sidebar" plugin (no other plugin). This could be a good test.

    Let me know.

  5. pboleo
    Member
    Posted 8 months ago #

    Hi.

    I installed the widget at another website, and it works perfectly at the frontpage. WordPress version is also 3.7.1 although it has another theme.

    I installed the widget at yet another website, and it works perfectly at the frontpage. WordPress version is 3.6.1 and it has the same theme as the first website.

  6. aldolat
    Member
    Plugin Author

    Posted 8 months ago #

    Could you install there the same theme as in acoolnet.com?

  7. pboleo
    Member
    Posted 8 months ago #

    The lusitaniatrading.com website has the same theme as the acoolnet.com website.

  8. aldolat
    Member
    Plugin Author

    Posted 8 months ago #

    OK, last try.
    In acoolnet.com disable all plugins except Posts in Sidebar and tell me if it works.

  9. pboleo
    Member
    Posted 8 months ago #

    Instead of disabling all plugins at once, i disabled one by one and tested it.

    When i disabled "WP Hide Post" (Version 1.1.9 by Robert Mahfoud) the posts started showing in Posts in Sidebar" on frontpage too.

    I use WP Hide Post so that those specific posts don't show on frontpage in the news section, so naturally they aren't available to your plugin either.

    I guess i'll have to think of a way to bypass this situation...

    Thanks for all your help, and congratulations on a great plugin.

  10. aldolat
    Member
    Plugin Author

    Posted 8 months ago #

    You are welcome! :)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags