WordPress.org

Ready to get started?Download WordPress

Forums

Post Meta Lost when moving host (2 posts)

  1. robsonfgjunior
    Member
    Posted 3 years ago #

    Hello everyone.

    I'm using templatic's Store theme. And they did the for the products as custom post types .. at least thats what it looks like. Anyway, to add prices, sizes, colors, and images to the posts it uses custom fields so you can imagine how important the post meta table is for my site :)

    I've created the whole site on local machine, added all the products to the store and everything. When the client agreed that everything was ok i bought a domain name and host and put it online. This is not the first time i do this, i'm on this business for years and i work with wordpress a lot! And this time, as usual, i uploaded all the files via ftp, and exported the database to an sql file. Opened the sql file on "text edit app" and did a find and replace from http://localhost to my domain name. Then finally, imported the altered sql file to the database.

    Everything in cool on the database now, post meta table is there, with the same data, but when i log into wordpress admin panel, i cant see any custom filed on my posts and worse, the site is missing all the images and prices, and colors, and sizes that was declared on the custom fields. But the table is there intact with the same data as the original table on my local server, is just wordpress cannot "read" the data.

    Weird right? i'm already behind schedule cause i promised the client it would take a day like it usually does, and here i am after 3 day long days of google and forum searches, pulling hair and drinking caffeine ... that last one actually did much more harm then good :p

    Please i beg for someone's help .. anything will be very appreciated :)
    this is the ulr btw: http://manuelamadeira.com/
    *Site is in portuguese.

    Thanks in advance

  2. Tara
    Member
    Posted 3 years ago #

    the site is missing all the images....

    -have you checked with your new host if there are any limitations/restrictions, etc.

    -make sure images are not blocked by hotlink protection, contact your webserver.

    - check path in Admin => Settings => Media

    - make sure wp-content/upload folder is writable (try 766, 767, or 777 permission).

Topic Closed

This topic has been closed to new replies.

About this Topic