WordPress.org

Ready to get started?Download WordPress

Forums

Post Links not working and no .htaccess file (10 posts)

  1. retrotshirtsuk
    Member
    Posted 5 years ago #

    Hi - first post from a WordPress newbie.

    I have installed WordPress and posted a couple of posts, but noe of the internal links work - they just go to "Page Cannot Be Displayed" error pages.

    I have looked through the various forums, and most seem to refer to me to the .htaccess file - which I didn't appear to have, so created one, then re-saved my Permalink structure again, back to:

    /%category%/%postname%/

    The re-naming of the URLs seem to work, but the pages they direct to aren't being created.

    My site is http://www.retrotshirtsuk.com - try clicking on any of the category pages - if you hover, you will see that the re-name has happened OK.

    Please can someone point me in the right direction.

  2. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    Here is the news you all ready know, http://validator.w3.org/checklink?check=Check&hide_type=all&summary=on&uri=http%3a%2f%2fwww.retrotshirtsuk.com%2f

    Is your htaccess in the root directory?

  3. retrotshirtsuk
    Member
    Posted 5 years ago #

    Thanks - kmessinger

    Yes, it's in the root, with the following code:

    Options +FollowSymlinks
    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  4. kmessinger
    Volunteer Moderator
    Posted 5 years ago #

    I think there should be a ? after error=404. Like this error=404?

    But, I don't know much about this. My htaccess does not have that line and all works fine. I also do not have this, Options +FollowSymlinks.

    Also, your links should be full path links.

  5. retrotshirtsuk
    Member
    Posted 5 years ago #

    OK, so the plot thickens......

    As we know, this page, doesn't work:

    http://www.retrotshirtsuk.com/category/funky-t-shirts/

    However, if you hack the URL and add in "index.php" in the URL string - it does work - example:

    http://www.retrotshirtsuk.com/index.php/category/funky-t-shirts/

    However, I don't want the latter to work, I want the former to work - ie without the index.php in the URL string.

    Does this help with getting to the bottom of this?

    Thanks again.

  6. Samuel B
    moderator
    Posted 5 years ago #

    well...you are on a windows server so your permalink choices are limited
    http://codex.wordpress.org/Using_Permalinks#Permalinks_without_mod_rewrite

    do you have to have windows?
    linux is faster and more easily configureable - permalinks being just one example

  7. retrotshirtsuk
    Member
    Posted 5 years ago #

    thanks - samboll

    It's the hosting site I've had this domain on for an age - and have a whole bunch of other stuff there.

    I know Windows isn't the be-all and end-all, but surely I can't be the only person on Windows with WordPress who doesn't want index.php in their URLs?

    Is there an .htaccess hack I can use to resolve.

    Thanks for your time.

  8. Samuel B
    moderator
    Posted 5 years ago #

    I understand, but since you don't own the server, it would be hard to configure. You don't say what flavor windows. Maybe someone with that specific one can help.

  9. retrotshirtsuk
    Member
    Posted 5 years ago #

    So, just to let you know, I had to shift over from Windows to Linux. Seemed a little extreme, but, hey, it worked.

    Thanks for all those that input.

  10. stevec828
    Member
    Posted 4 years ago #

    Hey guys, i too am using a windows server since i have other sites that are .net. And i too am experiencing the /index.php/ path issue. Have you or anyone else found a work around? Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic