WordPress.org

Ready to get started?Download WordPress

Forums

Post link gives error page (7 posts)

  1. AlisonMooreSmith
    Member
    Posted 6 years ago #

    I have used permalinks that use the post slug and a post id. I don't want any dates or categories in the url.

    The urls seem to be created correctly, but when I click on the post title from the index page to get to the article page, I get an error page.

    Can anyone point me to a fix? I don't want to add the index.php to every url. Is there a cleaner solution?

  2. flammobammo
    Member
    Posted 6 years ago #

    When you updated your permalink structure, did it write to the .htaccess file correctly? If you don't allow WordPress to modify your .htaccess file (by setting the file permission for it) then it can't write to it and you will have to do it manually before most of the links on your site will work.

  3. AlisonMooreSmith
    Member
    Posted 6 years ago #

    I created the .htaccess file and added the code manually as per the codex when I made the change. Still no deal.

  4. AlisonMooreSmith
    Member
    Posted 6 years ago #

    My .htaccess file now contains:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    That is all that's in there. Should there be something else?

    WP is creating the URLs correctly, but when I click on a title, it goes to an error page.

    If I change the permalinks setting back to the ugly default, the links revert and work fine.

    Any help appreciated.

  5. AlisonMooreSmith
    Member
    Posted 6 years ago #

    I was just told that the problem is my hosting. I use Mac OSX server 10.5. I was told that these permalinks would work if I was on Linux/Unix. Anyone have input on that?

    Pretty please?

  6. flammobammo
    Member
    Posted 6 years ago #

    That's definitely wrong, as I recently transferred my blog from a Windows box to a linux box. As for Mac I'm not sure, but throw out the credibility of wherever told you it has to be linux/unix!

    Did you try flushing your browser cache after making the permalink change? It might not be updating correctly. I normally just use Firefox but when I suspect I have a browser cache issue I load Internet Explorer which I've set to automatically flush it's cache every time it loads, just for my debugging ease of use.

  7. AlisonMooreSmith
    Member
    Posted 6 years ago #

    Thanks flammobammo. (What a name!) That didn't work. I guess I'll just go back to ugly links. Sure wish this worked better.

Topic Closed

This topic has been closed to new replies.

About this Topic