WordPress.org

Ready to get started?Download WordPress

Forums

Transposh WordPress Translation
[resolved] Post Language Selection Box Sticks After Publishing (4 posts)

  1. dserber
    Member
    Posted 1 year ago #

    The post language selection box does not allow changing of the language once a post has been published (on version 0.9.1).

    It appears that the option "Do automatic translation immediately after a post has been published" is what causes this problem when unchecked.

    I don't use the automatic machine translation component of your excellent plugin so not being able to change the post language after a post has been published without being required to automatically generate a machine translation is problematic.

    I have reproduced the problem on a fresh install of WordPress 3.5.1 with no plugins activated using version 0.9.1

    http://wordpress.org/extend/plugins/transposh-translation-filter-for-wordpress/

  2. dserber
    Member
    Posted 1 year ago #

    After a little more testing, I have found out that on new posts the language selection box within the post screen will not allow any other languages to be chosen other than the default language when the "Do automatic translation immediately after a post has been published" is unchecked.

  3. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the report,

    Had some people reporting this in the past and was never able to recreate this, will try now, and fix the code :)

    The solution I offered in those cases was to manually change the tp_language meta, so I hope it will be obsolete soon

  4. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic