WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Post is redirecting to a 404 (6 posts)

  1. ParkerWest
    Member
    Posted 3 years ago #

    Hello,

    I have a post that is suddenly redirecting to my homepage as a 404. Now I can't seem to get it back on the site even though it still shows up in my WordPress Dashboard.

    http://www.cardpaymentoptions.com/credit-card-processors/ipayment-review-complaints-and-rating/

    Back story:
    Last night I published a new review under the URL http://www.cardpaymentoptions.com/credit-card-processors/ipay. This is a review of a different company, however it seems to have caused an error with both reviews as they both started redirecting to a 404.

    Things I've tried to fix it, unsuccessfully:

    -Deleted the new ipay review
    -Deactivated plugins: W3 Total Cache, Relavanssi

    I could delete it and republish it, but I do not want to lose this post because it has 14 comments. Is there anyway to get it working correctly?

    The search engine and tag pages are still pulling the excerpt for it as you can see here: http://www.cardpaymentoptions.com/?s=ipayment

  2. ParkerWest
    Member
    Posted 3 years ago #

    Thank your for the response. If I edit the slug, it will change the whole URL right? That would cause the page to fall out of search unless I 301 it to the new URL (which is an option if I have to do it). Is there a way to just make it function properly without changing the slug?

  3. Yes, it would change the URL, but frankly, the URL doesn't work NOW so any link-juice from SEO is being lost. Right?

    Why doesn't it work? Canonical redirects. If you really MUST keep the URL as is, try this plugin.

    http://wordpress.org/extend/plugins/permalink-fix-disable-canonical-redirects-pack/

  4. ParkerWest
    Member
    Posted 3 years ago #

    This is really strange. I changed the slug but I'm still getting the same behavior: http://www.cardpaymentoptions.com/credit-card-processors/ipayment-review-complaints-and-rating-1/

    Event the shortcode isn't directing to the page: http://www.cardpaymentoptions.com/?p=671

    Any thoughts?

  5. ParkerWest
    Member
    Posted 3 years ago #

    I got it working by changing the permalink and then changing it back. Thanks for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic