WordPress.org

Ready to get started?Download WordPress

Forums

EasyRotator for WordPress - Slider Plugin
[resolved] Post-Installation errors (13 posts)

  1. ssaber
    Member
    Posted 1 year ago #

    Hello everyone,

    I followed the installation procedure (manual) for the EasyRotator plugin and I see the following error messages in WP:

    Warning: is_dir(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/smithran:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/smithran/public_html/wp-includes/functions.php on line 1311

    Warning: file_exists(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/smithran:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/smithran/public_html/wp-includes/functions.php on line 1302

    Warning: is_dir(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/smithran:/usr/lib/php:/usr/local/lib/php:/tmp) in /home/smithran/public_html/wp-includes/functions.php on line 1311

    EasyRotator Error!

    The WordPress uploads directory (usually wp-content/uploads) doesn't exist or isn't writable. Please make sure this directory exists and is writable

    I am hosting this website for a client and up until now they have not had any issues (or so they claim). I haven't changed anything server-side so I'm not sure what may have gone wrong (I'm sure they changed something). I re-installed the plugin from scratch and I am still getting those errors. For testing purposes I set the user/group to "nobody:cpaneluser" for the wp-content/uploads directory and that normally fixes write issues to it - however it didn't. I even tried 777 just for testing and the error did not go away. I tried Googling this error and someone mentioned that the .htaccess file needs to be writable (and it is), I'm looking for any advice that might help figure this out!

    Best,

    Samir

    http://wordpress.org/extend/plugins/easyrotator-for-wordpress/

  2. DWUser.com
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Samir,

    Thanks for your interest in EasyRotator for WordPress. Since these errors don't relate to the EasyRotator plugin files, I suspect that the problem may be unrelated to EasyRotator. Please try removing the wp-content/plugins/easyrotator-for-wordpress/ folder and see if the errors persist.

    Sincerely,
    Drew O'Neill

  3. ssaber
    Member
    Posted 1 year ago #

    I did remove the plugin and the errors went away - they come back when I install EasyRotator.

    Thank you,

    Samir

  4. DWUser.com
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Samir,

    Try adding the following to your server's php.ini configuration file:

    open_basedir = /home/smithran/public_html/

    Sincerely,
    Drew O'Neill

  5. ssaber
    Member
    Posted 1 year ago #

    I have a Cpanel/CentOs server. I have a few php.ini files:

    /usr/lib/php.ini
    /usr/local/lib/php.ini
    /usr/local/cpanel/3rdparty/etc/php.ini

    Wasn't sure which to use so I tried putting that on all and same problem.

    I don't have a php.ini in the /home/user of the Cpanel/Wordpress account.

  6. DWUser.com
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I recommend you contact your webhost and ask them to add /home/smithran/public_html/ to your open_basedir value. They'll know which file needs to be edited to ensure this value is applied.

    Sincerely,
    Drew O'Neill

  7. ssaber
    Member
    Posted 1 year ago #

    I have a dedicated server so I am the "web host" :/

  8. DWUser.com
    Member
    Plugin Author

    Posted 1 year ago #

    If you create a page with phpinfo() it will describe which php.ini file takes precedence as well as the current open_basedir.

    Sincerely,
    Drew O'Neill

  9. ssaber
    Member
    Posted 1 year ago #

    Thanks. The phpinfo() is showing the following for open_basedir:

    Local Value: /home/smithran:/usr/lib/php:/usr/local/lib/php:/tmp Master Value: /home/smithran/public_html/

    Which looks ok. It also says my php.ini is /usr/local/lib/php.ini which I have already tried updating with open_basedir = /home/smithran/public_html/

    I am looking at phpmyadmin & trying to find the open_basedir directive with no luck so far.

  10. DWUser.com
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Can you please post your wp-includes/functions.php file (post the code here: http://gist.github.com/ ) or open a support ticket and send it? I want to review the specific code that's raising this error.

    Sincerely,
    Drew O'Neill

  11. ssaber
    Member
    Posted 1 year ago #

  12. DWUser.com
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    This error seems to be originating from the native wp_upload_dir() method. Are you able to upload media to the WordPress media library in the WordPress dashboard? I recommend you create a script that attempts to write a test file to the wp-content/uploads/ directory (e.g. wp-content/uploads/test.txt) and see if that works. I suspect that there's some sort of permissions issue, or that your server paths have changed but the WordPress configuration hasn't been appropriately updated.

    Sincerely,
    Drew O'Neill

  13. ssaber
    Member
    Posted 1 year ago #

    Wow after all of this trouble turns out the issue was the following:

    In Settings "Miscellaneous" >Store uploads in this folder:
    The entry was "/wp-content/uploads" rather than "wp-content/uploads"

    Found it from this thread - http://wordpress.org/support/topic/open_basedir-restriction-in-effect-1?replies=12

    I had never set that (must've been the client trying to fix the issue).

    Thanks again for your help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.