WordPress.org

Ready to get started?Download WordPress

Forums

User Hierarchy
[resolved] Post install - site isn't working very well (3 posts)

  1. EyeAmN8
    Member
    Posted 1 year ago #

    First off, the features for this plugin are great! After we installed it, we noticed that we were not able to get to the "all users" area or just about anything that has to do with users. It has affected users for every role except newly created roles post plugin install.

    Now the site is not functioning properly, and almost all pages regardless of content take a long time to load(if they load).

    We have now deactivated the plugin and the problem still exists.

    Is there anything that you know of that may be causing these types of issues?

    http://wordpress.org/extend/plugins/user-hierarchy/

  2. EyeAmN8
    Member
    Posted 1 year ago #

    So I looked into this a bit more and noticed that in phpMyAdmin a process was showing as locked multiple times: `
    SELECT DISTINCT
    SQL_CALC_FOUND_ROWS wp_users.ID
    FROM wp_users
    INNER JOIN wp_usermeta ON ( wp_users.ID`

    I found that it was coming from roles.php starting at line 197. I commented it out and the plugin seems to be working just fine.

    Going through the code it looks like it only has to do with blog posts which I'm not concerned with, but I may be wrong.

    I consider myself to be a pretty good php programmer, but not that familiar with wordpress and it's api.

    Can you please confirm that this will not affect the plugin's use, or possibly update the plugin to fix this matter.

    Thanks

  3. Jesper van Engelen
    Member
    Posted 1 year ago #

    Thanks for reporting this problem. I have been able to reproduce it, and the only fix I can currently apply for this is to remove the functionality to filter the user view.

    I have just released version 0.1.2 which addresses this issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.