WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Post Images not showing up in Feed (12 posts)

  1. labedford
    Member
    Posted 4 years ago #

    My post images are not showing up on my RSS Feed and I can't figure out why. (could it just be my browser?)

    They just show a grey box with the red cross and name of the image. I have full text showing (changed that about a week ago from excerpt).

    I am using version 2.8.5

    My feed is http://aquapebble.co.uk/feed or http://feeds.feedburner.com/aquapebble

  2. stvwlf
    Member
    Posted 4 years ago #

    Are the image URL's complete URL's starting with http://, or relative URL's? You need complete URL's in a feed.

  3. labedford
    Member
    Posted 4 years ago #

    All my images in my posts start with:

    <img src="http://aquapebble.co.uk...

    Not sure what a relative URL is.

  4. stvwlf
    Member
    Posted 4 years ago #

    The URL in your feed for the Facebook image that is showing up as a red X in Internet Explorer is
    http://aquapebble.co.uk/wp-content/uploads/2009/10/facebook.jpg

    When I paste that into my browser address bar it comes up with a 404 page not found - the image is not at the URL that is in the feed.

    In WordPress admin, go to Settings / Misc and make sure the upload URL is set to where you actually have the images. If you are not storing images by year and month then turn that setting off. However I didn't find the image at
    http://aquapebble.co.uk/wp-content/uploads/facebook.jpg
    either.

    Your actual image location is evidently not where WP is looking for your images, or they are no longer on the server.

  5. Shane G
    Member
    Posted 4 years ago #

    Hi,

    Check with this plugin:

    http://wordpress.org/extend/plugins/wp-rss-images/

    Thanks,

    Shane G.

  6. labedford
    Member
    Posted 4 years ago #

    stvwlf the odd thing is that the image is in that folder ( http://aquapebble.co.uk/wp-content/uploads/2009/10/facebook.jpg ) and when I put that url in I also get a 404 - the post has that url as link to image and I double checked in file manager. It appears on my site fine.

    Thanks Shane I installed that plugin and the image appeared for 1st post and when I refreshed it was gone again.

    Could I have installed a security feature that could affect this?

  7. stvwlf
    Member
    Posted 4 years ago #

    Hi

    More than likely something is not allowing direct access of your image as a URL yet allowing it to display as part of a webpage. Do you have hotlinking prevention turned on in your webhosting control panel? If you do, try disabling it & see if you then can access the image at that URL. If you can't see the image when you paste its URL in the browser address bar then its not going to work by RSS either, evidently.

  8. labedford
    Member
    Posted 4 years ago #

    I logged a support call with my web host and have gone around in circles. I disabled the hotlink protection and it did not change it.

    They made some change to my htaccess file and the pictures showed but if I typed http://aqaupebble.co.uk/feed - I got a page could not be found. Then when they changed it back so when I typed that url it showed my feed (redirects to feedburner) my pictures don't show. They then just gave up and said they don't know what is causing it.

    I am trying to find out what they did to my htaccess file as I am sure that will provide clues.

  9. stvwlf
    Member
    Posted 4 years ago #

    One thing I suggest you do is to reset your permalinks.

    In admin go to Settings / Permalinks. Write down what your permalinks are set to now. Then set them to default and save the changes. Check your feed & see if it works & see if your images work.

    If they do, then change your permalinks back to what they were prior to this and check again.

    Resetting the permalinks forces WP to rewrite the htaccess code it requires to run.

  10. labedford
    Member
    Posted 4 years ago #

    I tried that and still no pictures. From what I can see is my web host renamed my htaccess file and it allowed pictures to show in my feedburner feed but the site feed showed as page not found.

  11. labedford
    Member
    Posted 4 years ago #

    I have sorted this out now. I added feedburner to my accepted list on hotlink protection and it now works. It is really odd that turning off hot protection link did not work.

  12. radeonxt
    Member
    Posted 4 years ago #

    Hi, what kind of hotlink protection plugin are you using?

    I'm using WP hotlink protection and have a similar error...

    I'd like to fix this.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags