WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Post Images Do Not Display After Server Migration (11 posts)

  1. er8306
    Member
    Posted 2 years ago #

    So I migrated my multisite setup to a larger server on Hostgator and while most of my sites work completely fine I have one domain that no longer shows images for posts. I'm pretty tech savvy and after looking at this problem for over 3 days I'm at a loss, so any help would be appreciated. Relevant details:

    *Linux Server
    *Checked and re-checked htaccess file
    *Had host check httpd.conf file
    *URL: http://www.youprettythingsblog.com with subdomain youprettythings.roundwallmirror.net

  2. It's a mapped domain then?

    http://www.youprettythingsblog.com/files/2011/07/Travis-Bland-by-Jeremy-Kost-MaleModelSceneNet-06a-240x300.jpg and http://youprettythings.roundwallmirror.net/files/2011/07/Travis-Bland-by-Jeremy-Kost-MaleModelSceneNet-06a-240x300.jpg should be the same then right?

    But youprettythings.roundwallmirror.net doesn't come up at all. Did wildcard subdomains get brought back?

  3. er8306
    Member
    Posted 2 years ago #

    Yes, it's a mapped domain. Those URLs are effectively the same.

    For me http://youprettythings.roundwallmirror.net forwards to the www URL. I also do have the wildcard domain of *.roundwallmirror.net

  4. er8306
    Member
    Posted 2 years ago #

    I removed the extra content from my .htaccess that was added from a w3 total caching plugin and I have disabled that plugin. So currently I have the below in my htaccess file:

    # WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>

  5. That's the subDIRECTORY htaccess.

    This is subdomain:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress
  6. er8306
    Member
    Posted 2 years ago #

    Ahh, I see. Thanks, I'll replace that.

  7. er8306
    Member
    Posted 2 years ago #

    I have the updated .htaccess file in but images are still a no go. I'll wait a bit to see if the server is cached.

  8. er8306
    Member
    Posted 2 years ago #

    So I just noticed an odd thing. I was browsing the site through some of the old posts and I noticed that a few posts have images but they link to something like:

    http://youprettythingsblog.files.wordpress.com/2011/03/versace-blue348.jpg?w=218

    Do you know what would cause this linking to display but the others not?

  9. er8306
    Member
    Posted 2 years ago #

    Resolved - I believe it was the .htaccess file that helped to resolve the image problem, but also I missed the most obvious thing in the world; the images weren't migrated over correctly so the blogs.dir folders were empty until I re-uploaded the images. Thanks for the help Ipstenu!

  10. *hah* That would do it!

Topic Closed

This topic has been closed to new replies.

About this Topic