WordPress.org

Ready to get started?Download WordPress

Forums

AutoNav Graphical Navigation and Gallery Plugin
Post Image Thumb pulling wrong image (3 posts)

  1. mlddev
    Member
    Posted 1 year ago #

    I am using the shortcode

    [autonav display="posts:product,list,notitle,thumb" columns="4" count="8" postid="product_cat:ring,necklace,earring"]

    to pull products on the front page of a site. All was fine until I added additional images to each product post. Once I uploaded (attached) additional images the autonav shortcode selected one of the alternate images instead of the Featured Image I had designated.

    Also, as a test I reordered the images attached to a given post to see if that would change which images autonav had associated with the post, but it does nothing.

    Any idea why this is happening?

    you can view the site through this link ( site is in maintenance )

    Notice the featured images for each product are not what is showing on the front page.

    Thanks for any help here, I love the plugin.

    http://wordpress.org/extend/plugins/autonav/

  2. mlddev
    Member
    Posted 1 year ago #

    Oh, I am using WP 3.4.2 and the 1.5.0 version of the plugin

  3. mlddev
    Member
    Posted 1 year ago #

    I think I figured it out.

    I modified the code to:

    [autonav display="posts:product,list,notitle,thumb,attachment" order="ASCE" columns="4" count="8" postid="product_cat:ring,necklace,earring"]

    With display="attachment" and order="ASCE" it's now picking the correct image. Not ideal but it works... why does it ignore the Featured Image setting when I have multiple attachments to a post?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.