WordPress.org

Ready to get started?Download WordPress

Forums

Pinboard
Post grid is bugging (7 posts)

  1. Mathias Joergensen
    Member
    Posted 11 months ago #

    Hello!

    I'm currently setting up a website with the theme Pinboard, everything is going smoothly however the grid display on my front page is bugging, it's currently shows 2 posts and then it skip's a line down.

    I tried looking at the settings where it said if I have a sidebar enabled (Which im unsure if i have or not, I told the layout to be the one on the far right with no sidebar so i suppose I did it right) it would take one of the boxes and not display it, so I told ti to display 4 and it worked but it looks kinda weird, there is gaps between the posts and on the second line there is no post underneath the first one displayed, so it looks all mashed up.

    I did a few changes to the CSS under Apperance which was some img padding, but I added a class to that so I know I didn't break anything there!

    Any help? Thanks!

    - Mathias Joergensen

  2. paul.a.cunn
    Member
    Posted 11 months ago #

    Do you have a link to your site or a screen shot of the issue.

  3. Mathias Joergensen
    Member
    Posted 11 months ago #

    Click here to view the site.
    Click here for a screenshot.

    And I don't legit own the site, was setting it up for a client.

  4. paul.a.cunn
    Member
    Posted 11 months ago #

    OK so it appears that somehow a right margin of 5% was added to each column. I am not sure if this was you or something that is built in. The css that is causing the issue is shown below. If you change this to 0% it will work perfectly like it should. Currently each column has a width of 33% and since you have added a 5% margin it is taking up more than 1/3 of the page. So currently each column is 38% of the page so this is why you can only fit 2 posts per row. Just change the 5% to 0 or just kill the css your choice.

    .column {
    margin-right: 5%;
    }

  5. Mathias Joergensen
    Member
    Posted 11 months ago #

    Problem is the only CSS I added to the theme itself is a custom class called .skills and I only added that class to certain images, so I don't see what's causing it.

    Should I just add

    .column {
    margin-right: 5%;
    }

    to the CSS to fix it, or can you explain a bit clearer exactly what's going on?

  6. paul.a.cunn
    Member
    Posted 11 months ago #

    just add

    .column {
    margin-right: 0%;
    }
  7. Mathias Joergensen
    Member
    Posted 11 months ago #

    Thanks!

    But now a new problem occured, they seem to slope slightly downwards?

    Take a look!

Reply

You must log in to post.

About this Theme

About this Topic

Tags

No tags yet.