WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Post excerpts missing on home page (8 posts)

  1. jlwchennai
    Member
    Posted 1 year ago #

    Hi,
    I am using the Pinboard theme for the following site: http://www.whitedesignallies.com

    I have recently added the Column-Matic plugin to enable a metaslider to sit to the right of post text. However, since I did this the text excerpt has disappeared from the post thumbnails on the home page.

    Is there a way to bring back the excerpt whilst keeping my column formatting on the individual posts?

    Any help is appreciated as I am new to WP.

  2. simple1
    Member
    Posted 1 year ago #

    It looks like you have an empty paragraph tag at the top of all of your posts. I wonder if deleting them might fix the problem.

  3. jlwchennai
    Member
    Posted 1 year ago #

    I think the empty paragraph is where the code is placed into the beginning of the post to split the content into two columns as below:

    [column width="50%" margin_right="5%" background="#FFFFFF"] <strong>White</strong> is currently working on another 4 bedroom luxury apartment in Hiranandani towers...

    This appears to be creating the empty paragraph below the post titles on the home pages - especially as it only occurs for posts where we have split the content into two columns.

  4. jlwchennai
    Member
    Posted 1 year ago #

    Just checked this by removing the code at the start of the post and the excerpt returns. How can i keep the code AND the excerpt?!

  5. simple1
    Member
    Posted 1 year ago #

    Are you placing your excerpt in the Excerpt field?

  6. jlwchennai
    Member
    Posted 1 year ago #

    There is no reference to excerpt field in the style.css. The excerpt text on the home page is just the first few lines from the post. I think the above code used to split the post into columns has thrown the home page which is looking for the text.

    I need a way round that!

  7. simple1
    Member
    Posted 1 year ago #

    The excerpt field is within your posts. I think the column code is causing the excerpt from being created automatically, so you have to copy the first few lines of your post into the Excerpt field.

    Try this: Open one of your posts. Click on the Screen Options tab at the top of the page. Make sure Excerpt is ticked. You should see the Excerpt field under the Text Editor window. Type or paste your excerpt there.

  8. jlwchennai
    Member
    Posted 1 year ago #

    Thanks. That seems as though it will work. Unfortunately I've been asked to change the layout so this whole exercise is now pointless!

    Thanks all the same, I will know for next time!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.