WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Post Editor Stuck in HTML Mode (23 posts)

  1. palmettostar
    Member
    Posted 2 years ago #

    This evening I was writing out a blog post and went to insert some coding and noticed it was already in the HTML tab. I attempted to switch it the visual tab so I could continue working but my editor will not change from the HTML mode.

    I have searched for a fix and tried everything from upgrading (I upgraded to 3.4.1 tonight), disabled all plugins, deleted & reuploaded the wp-admin & wp-include files.

    I'm not sure what else to do to make it work? I have a second installation of WordPress on my server linked to a different domain and that one is working fine. I don't know when I started having this problem as I haven't blogged on this WordPress install in sometime, but I haven't changed anything on the server or uploaded anything since I started blogging again aside from upgrading.

  2. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Can you post your site URL?

  3. palmettostar
    Member
    Posted 2 years ago #

    blissful reviews

    I did a manual upgrade and deleted and reuploaded everything but my content folder. Disabled plugins and reenabled one, checked to make sure I didn't disable the editor under my user name...it still doesn't work.

  4. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Try to revert to Twenty Eleven and see if the problem persists. Your theme seems to be causing the problem because it may be outdated/ broken or even infected.

  5. Sabinou
    Member
    Posted 2 years ago #

    No panic, Krishna, this has no need to be an infection.

    Over the past years, I've had this a couple of times. Options adding themselves one over the other in the user's database options, until some of the conflict with each other.

    There are two solutions, a complicated and a simple one :
    - create yourself a new user in your admin, the new user shouldn't have the problem. Done, piece of cake.
    - open phpmyadmin, browse to the part ruling the options of the users, your bugged user and the new user that doesn't have the bug, and manually copy-overwrite-paste the new user's unbuggy options to your old user's buggy option

    However, if you create a new user and that user still has that problem, then honestly I can be of no help.

  6. palmettostar
    Member
    Posted 2 years ago #

    Changing the theme to a different one doesn't fix the problem. I also have the same theme I'm using (before switching to Twenty Eleven) on my other domain where WordPress is working fine.

    I will try Sabinou's option of creating a new user and see if that works. Where would you find phpmyadmin at?

    Here are two screen shots of what my add new post area looks like when I go to add a new post: screen shot 1 and screen shot 2

    Edit: I added a new user the simple way according to Sabinou and it didn't fix the problem :( I use Chrome (it's updated) and tried it in Firefox & IE as well and no working.

  7. Sabinou
    Member
    Posted 2 years ago #

    Then I'm sorry I'm unable to help !

    Just in case, it can't hurt, did you ask your web host if they didn't change some stuff ?

  8. palmettostar
    Member
    Posted 2 years ago #

    Eventually I guess it'll be fixed. The thing is I have another install on the same server with the same web host and don't have the problem. Both installs have been on the server forever.

  9. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Check settings in the dashboard, users, your profile and make sure disable visual editor is not checked.

  10. palmettostar
    Member
    Posted 2 years ago #

    Kmessinger I have done that, its unchecked. I also tried checking it, saving it and unchecking again.

    I have browsed through the forums and it seems a lot. Of people are having issues, I've tried all the recommendations found and nothing works so far

  11. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    I think you can log in here, http://blissful-reviews.com:2082/ go to MySQLAdmin. Open the table called usermeta. Click on browse and check user capabilities. Yours should say, a:1:{s:13:"administrator";s:1:"1";}

  12. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Try to revert to Twenty Eleven and see if the problem persists. Your theme seems to be causing the problem because it may be outdated/ broken or even infected.

    I wrote the above opinion just because of THIS REPORT.

    Please go through the report.

  13. Sabinou
    Member
    Posted 2 years ago #

    Ah, a thing I didn't think of, maybe your browser cached some blog javascript and made a mess out of it... Maybe with a new browser that didn't visit your blog's admin...

  14. palmettostar
    Member
    Posted 2 years ago #

    Extremely frustrating...none of the suggestions above have worked. I'm not exactly sure what to do. I can still post to my blog, however I insert many images and coding under cuts that I can't do now because it doesn't insert properly.

  15. Sabinou
    Member
    Posted 2 years ago #

    I feel your pain, I wish I could help :(
    Random thinking : if you take all of your blog files (well, save wp-content, wp-config, and the like, you see the ideao) and copy them to another of your blogs that doesn't have the problem, will the problem appear ?
    Or (safer, lol) copying a healthy blog's stuff into your broken blog, and see if there's still the problem.
    How to say, I wonder if this is domain-centric or wordpress-centric.

  16. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  17. palmettostar
    Member
    Posted 2 years ago #

    @Esmi - I've tried all of those.

    Is there anyway I can backup my entire blog (all posts, comments, categories, tags, etc etc) so I can delete my install and reinstall?

    It seems to me that the wp-admin/post.php & wp-admin/new-post.php pages aren't loading correctly but I'm not sure why?

  18. esmi
    Forum Moderator
    Posted 2 years ago #

    Did you try the re-upload as I suggested?

  19. palmettostar
    Member
    Posted 2 years ago #

    @Esmi - that is one of the first things I tried. I re-uploaded everything except the wp-content folder and still doesn't work. And like I said previously, I have another install of WordPress on the same server which is used for another domain hosted on my account and that install works fine.

    I'm going to try and do a new extra install and see if that has issues so I can rule out my current install or something.

  20. palmettostar
    Member
    Posted 2 years ago #

    A few minutes ago, I did a completely new install in a new directory under blissful-reviews.com (I installed at blissful-reviews.com/testblog) and guess what THE VISUAL EDITOR (post.php & new-post.php) WORKS LIKE NORMAL...

    SO waht the heck is wrong with my other install? I tried reuploading all the files to Blissful Reviews install but that didn't fix the problem.

  21. Sabinou
    Member
    Posted 2 years ago #

    Palmettostar, what if, by FTP, you delete all the blog contents (save the customized stuff, wp-contents, wp-config, you know already), and then MOVE the working test blog's contents to the main blog ?

    If the problem comes back, the issue isn't with wordpress.
    (With that, that would remain to be figured)

  22. palmettostar
    Member
    Posted 2 years ago #

    @Sabinou - I will try that. Otherwise, I will just delete the whole install (backup my blog posts etc etc) and import them back into WordPress. On the new install under the new directory, I imported my blog posts from the install that isn't working and the visual editor still works.

  23. palmettostar
    Member
    Posted 2 years ago #

    I finally fixed it. I did the last suggestion you made Sabinou and deleted all the files except my wp-content folder & the wp-config folder and this time it worked. Previously, I was just overwriting them instead of actually deleting them off my server...I just logged in and the visual editor appears to be back to normal & working. NO IDEA what the problem was but obviously I had a corrupt or broken file somewhere. :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags