WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Post Editor missing in WP 3.5 after upgrade (62 posts)

  1. brandonchicago
    Member
    Posted 1 year ago #

    I upgraded this morning and now my visual and text editors are blank boxes with no content. Disabled all plugins and changed the theme to Twenty Eleven, still no love. Tried in FF 17 and latest version of Chrome.

  2. brandonchicago
    Member
    Posted 1 year ago #

    Screen options and Help at the top also don't work anywhere in the Dashboard.

  3. keesiemeijer
    moderator
    Posted 1 year ago #

    try:
    - reading the troubleshooting 3.5 master list to see if any of your problems is listed there: http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    - flushing any caching plugins you might be running, as well as server and/or browser caches.

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems.

    - re-uploading all files & folders - except the wp-content folder from a fresh download of WordPress. by using FTP or whatever file management application your host provides (Manual Update).

    - re-running the upgrade via wp-admin/upgrade.php

  4. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Delete the wp-admin and wp-includes folders. Using ftp, replace them with copies of the wp-admin and wp-includes from wp3.5.

  5. thelostswede
    Member
    Posted 1 year ago #

    Having exactly the same problem, doing the automatic re-install didn't help, trying a manual re-install now...

  6. Reinharts
    Member
    Posted 1 year ago #

    Same here. Tried manually updating all files, disabling all plugins, flushing cache and using default theme.

    Nothing.

  7. thelostswede
    Member
    Posted 1 year ago #

    That didn't help at all, still blank edit boxes that I can't even click in, no editor buttons etc. :(

  8. Reinharts
    Member
    Posted 1 year ago #

    Yeah there are at least 5 threads on this so I assume the WP gods know all about it. Hopefully we get a fix soon.

  9. John Blackbourn
    Member
    Posted 1 year ago #

    brandonchicago, thelostswede, Reinharts:

    Are you seeing any JavaScript errors on the post editing screen? In Firefox and Chrome you can hit ctrl+shift+J to get the JavaScript console. Post them here if you can see any errors.

  10. brandonchicago
    Member
    Posted 1 year ago #

    I believe I was at 3.4.2 when I upgraded to 3.5.

    I tried removing the /wp-includes and /wp-admin directories and manually installing those directories from a fresh download of WP 3.5 via FTP. Still nothing.

    Seems to be an issue with jquery. No hovers work, anything with a dynamic UI element doesn't work, and the Add Media button doesn't work.

  11. thelostswede
    Member
    Posted 1 year ago #

    Indeed I do, not that I have the faintest idea what it means

    Failed to load resource: the server responded with a status of 403 (Forbidden) http://cravings.tw/wp-admin/load-scripts.php?c=0&load=jquery,utils,plupload,plupload-html5,plupload-flash,plupload-silverlight,plupload-html4,json2&ver=3.5
    Failed to load resource: the server responded with a status of 403 (Forbidden) http://cravings.tw/wp-admin/load-scripts.php?c=0&load=admin-bar,hoverIntent,common,schedule,wp-ajax-response,autosave,jquery-color,wp-lists,quicktags,jquery-query,admin-comments,sugg&load=est,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,post,thickbox,underscore,shortcode,backbone,media&load=-models,wp-plupload,media-views,media-editor,jquery-ui-position,wp-pointer,word-count,editor,jquery-ui-resizable,jquery-ui-dragg&load=able,jquery-ui-button,jquery-ui-dialog,wpdialogs,wplink,wpdialogs-popup,wp-fullscreen,media-upload&ver=3.5
    Uncaught ReferenceError: jQuery is not defined post.php:1136
    Uncaught ReferenceError: getUserSetting is not defined /wp-includes/js/tinymce/plugins/wordpress/editor_plugin.js?ver=358-23156:1
    Port error: Could not establish connection. Receiving end does not exist. miscellaneous_bindings:235

  12. Reinharts
    Member
    Posted 1 year ago #

    Tons John,

    Failed to load resource: the server responded with a status of 403 (Forbidden) http://hbowatch.com/wp-admin/load-scripts.php?c=0&load=jquery,utils,plupload,plupload-html5,plupload-flash,plupload-silverlight,plupload-html4,json2&ver=3.5
    Uncaught ReferenceError: jQuery is not defined akismet.js:1
    Uncaught ReferenceError: jQuery is not defined et-ptemplates.js:1
    Uncaught ReferenceError: jQuery is not defined jquery.fancybox-1.3.4.js:1156
    Uncaught ReferenceError: jQuery is not defined post.php:47
    Uncaught ReferenceError: jQuery is not defined post.php:65
    Uncaught ReferenceError: jQuery is not defined post.php:1463
    Failed to load resource: the server responded with a status of 403 (Forbidden) http://hbowatch.com/wp-admin/load-scripts.php?c=0&load=admin-bar,hoverIntent,common,schedule,wp-ajax-response,autosave,jquery-color,wp-lists,jquery-query,admin-comments,suggest,jquery&load=-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,postbox,post,thickbox,underscore,shortcode,backbone,media-models,wp&load=-plupload,media-views,media-editor,jquery-ui-position,wp-pointer,word-count,editor,jquery-ui-resizable,jquery-ui-draggable,jquer&load=y-ui-button,jquery-ui-dialog,wpdialogs,wplink,wpdialogs-popup,wp-fullscreen,media-upload&ver=3.5
    Uncaught ReferenceError: jQuery is not defined post.php:2078
    Uncaught ReferenceError: getUserSetting is not defined

    Thanks!

  13. XIIIzen
    Member
    Posted 1 year ago #

    You can quickly fix this one as it may be related to wordpress not being able to load jquery (I had this issue).

    Just add this to your wp-config file : define('SCRIPT_DEBUG', true);

    it will fix the editor along with the menus and other things I have not discovered. It may slow down the admin side of your site, but your users would be happy.

    Also Ihave found Premise and Opt-In Skin errors are also fixed this way.

  14. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    All should read the troubleshooting 3.5 master list to see if solution is there: http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    That type of error is normally caused by javascript errors and usually caused by a plugin but try different browsers if you can.

  15. brandonchicago
    Member
    Posted 1 year ago #

    @johnbillion

    Yes, lots of errors and warning.

    Errors include:
    JQuery is not defined (/wp-admin/post.php?post...line 1327)
    getUserSetting is not defined (/wp-includes/js/tinymce/wp-tinymce.php...line 22)
    this.getDoc(..) is not defined (/wp-includes/js/tinymce/wp-tinymce.php...line 2).

  16. John Blackbourn
    Member
    Posted 1 year ago #

    Thanks all. This could well be an issue similar to a previously fixed one (here). It sounds like something on the server is blocking the requests to the JavaScript loader.

  17. Samuel Wood (Otto)
    Tech Ninja
    Posted 1 year ago #

    How to solve this sort of problem:

    First, clear your browser caches. You want to make sure that the browser is indeed downloading all the javascripts and such and not trying to use old versions.

    Second, if it's still not working after a full clear and refresh, then check the Javascript console for errors. This will tell you what sort of problem you're having.

    A 403 forbidden means that your browser isn't able to load the scripts up because your server isn't allowing it. Unfortunately, this is a hard one to solve. Anything could be blocking the server. Check your .htaccess files for anything strange, and/or ask your host what's going on. Also try a full manual upgrade, to make sure all the WordPress files are there and correct.

    If you can actually load those links in your browser, then you should see all the code and that means that you should be fine.

    Any "not defined" messages mean that your browser is not loading all the scripts. Same basic problem, the trick is just to figure out why.

  18. brandonchicago
    Member
    Posted 1 year ago #

    @XIIIzen

    That worked! Sounds like it's not the best solution for the problem, but now I can use the admin again. :)

    I added this script to my wp-config.php file: define('SCRIPT_DEBUG', true);

    Just to be clear, I had disabled all plugins and changed the theme back to Twenty Eleven and I was still getting the Jquery error, so I'm not sure if it was just a perfect storm of bad things happening or if there's a bug in 3.5. Hopefully this helps others in the meantime who run into this problem.

  19. XIIIzen
    Member
    Posted 1 year ago #

    @brandonchicago

    I agree it's just a quick and dirty solution. But it will allow you to work on the site normally while the issue is fully resolved.

    It may be that something went wrong with the update of the jquery libraries on the latest update. Not sure what tho, I'm still going around and fixing problems before I debug anything. :)

  20. brandonchicago
    Member
    Posted 1 year ago #

    I think I found the cause.

    I'm using the BulletProof Security plugin, and even though I disabled the plugin, it leaves the .htaccess file full of "Bulletproofing". When I changed the .htaccess file back to "Default Mode" and activated it, the JQuery error disappeared and the admin screen worked.

    Sounds like BulletProof Security is the issue.

  21. XIIIzen
    Member
    Posted 1 year ago #

    Good call!
    We must contact the developer ASAP, as I'm also using that plugin, not sure if this is the case for everyone.

  22. AITpro
    Member
    Posted 1 year ago #

    We leave the root .htaccess and wp-admin .htaccess files behind on plugin deletion to prevent catastrophic user error, but this needs to be stated more clearly/repeated in several places that are "in your face". ;)

    I upgraded this morning and now my visual and text editors are blank boxes

    Can you give me exact details so that i can look at this and see what needs to be done/what needs to be allowed/etc. Thanks.

  23. AITpro
    Member
    Posted 1 year ago #

    At first glance it looks like load-scripts.php needs a skip/bypass rule created in the wp-admin htaccess file, but since i am not 100% sure of where the error is occurring/conditions when the error occurs then any details you can provide will narrow that area down.

  24. XIIIzen
    Member
    Posted 1 year ago #

    Thanks for showing up AITpro :)

    I knew we could count with you to help on this one. Is there any details I can give you to help you see if there is an issue?

  25. attikon
    Member
    Posted 1 year ago #

    It's a .htaccess problem.

    It is mostly happening on blogs with BulletProof Security plugin. Even if you deactive it, the "secure .htaccess" file it had created stays in place and fully operational.

    To FIX this issue (if you are using BPS) activate the plugin, go to the Security Modes tab, check the red "Default Mode WP Default htaccess File" radio button and click on Activate.

  26. WayneM1
    Member
    Posted 1 year ago #

    I had to use revert to the default .htaccess in root and admin folders to get things working again.

    Yes, looks like BulletProof Security is the problem on my site. Excellent plugin. I'm sure there will be a fix soon enough.

    Amazing how many people are/were effected by this. All BPS users?

  27. AITpro
    Member
    Posted 1 year ago #

    @Xlllzen - the details i am looking for are does this problem occur generally. ie without involving another plugin or any other action on your part or does the error occur when trying to perform an action or is there a plugin involved in the process of the action that you are doing? Thanks.

  28. Samuel Wood (Otto)
    Tech Ninja
    Posted 1 year ago #

    @AITpro:
    The particular rule in question in your plugin that is causing the problem is this one:

    RewriteCond %{QUERY_STRING} ^.*(\[|\]|\(|\)|<|>).* [NC,OR]

    WordPress's load-scripts.php URL can, as of 3.5, have square brackets in it, which this rule blocks.

    For example, this URL is valid:
    http://localhost/wp/wp-admin/load-scripts.php?c=1&load[]=jquery,utils,json2&ver=3.5

    The load[] was changed from load because of a problem where the length of the load parameter could get too long for some webservers to handle properly. So now it's split into a PHP array for handling this sort of thing.

    Removing that line from the .htaccess in the wp-admin will solve the problem.

  29. AITpro
    Member
    Posted 1 year ago #

    Thanks Otto - this damn rule has been nothing but a pain in the rear since day one. Consider it permanently modified ASAP in both the root and wp-admin .htaccess file. Square brackets are safe enough - I went too far by including them is this filter. I will release a BPS update ASAP that will preg_replace this damn pain in the neck rule.

  30. XIIIzen
    Member
    Posted 1 year ago #

    Thanks AITpro and Otto!

    It's great to have such an active members like you around :)

Topic Closed

This topic has been closed to new replies.

About this Topic