WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Post Editor missing in WP 3.5 after upgrade (62 posts)

  1. 3five
    Member
    Posted 1 year ago #

    Thanks Otto!

  2. attikon
    Member
    Posted 1 year ago #

    Great cooperation guys :)

    Thanks Otto for providing the helpful insight and AITpro for the extremely fast involvement!

  3. brandonchicago
    Member
    Posted 1 year ago #

    Thanks AITpro & Otto! Really appreciate the help in getting that great plugin to play nice with WP again.

  4. Reinharts
    Member
    Posted 1 year ago #

    Thanks guys but I tried this (had BulletProof a long time ago) and it still isn't working. My HTACCESS looks like this:

    # BULLETPROOF PRO 5.D DEFAULT .HTACCESS

    # If you edit the line of code above you will see error messages on the BPS Security Status page
    # WARNING!!! THE default.htaccess FILE DOES NOT PROTECT YOUR WEBSITE AGAINST HACKERS
    # This is a standard generic htaccess file that does NOT provide any website security
    # The DEFAULT .HTACCESS file should be used for testing and troubleshooting purposes only

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Thanks!

  5. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

  6. Reinharts
    Member
    Posted 1 year ago #

    Okay so I figured it out.
    Not only do you have to do DEFAULT BPS Mode. You have to (more importantly?) activate Default mode for your wp-admin htaccess file taht BPS creates.

    Uninstalling this plugin now.. :(

  7. Reinharts (and anyone else who isn't using BPS) - Please make your own topic :)

    When a topic is resolved, we generally don't come back to look to help people. It's totally okay (encouraged!) to make your own topics :D

  8. AITpro
    Member
    Posted 1 year ago #

    BPS .47.7 has been released. All Square Brackets characters are no longer filtered in either the Root .htaccess file or the wp-admin .htaccess file. The upgrade to .47.7 will automatically preg_replace the "bad" filters with new filters. Should have been done a long time ago - it would saved me a fortune in unneeded bottles of Aspirin. ;)

  9. titusraj
    Member
    Posted 1 year ago #

    This fix from X111zen worked for me

    Just add this to your wp-config file : define('SCRIPT_DEBUG', true);

  10. ipouk
    Member
    Posted 1 year ago #

    Thank you all above! Resolved!

  11. joenelli1
    Member
    Posted 1 year ago #

    I deactivated "CKEditor for WordPress" plugin and it solved the problem

  12. thelostswede
    Member
    Posted 1 year ago #

    It was indeed BPS that was causing problems, all good now

  13. jennaleeg
    Member
    Posted 1 year ago #

    This worked for me!!! THANK YOU :)

  14. Mark Bremmer
    Member
    Posted 1 year ago #

    @AITpro:
    There is a Pro fix coming soon? I tried the #RewriteCond %{QUERY_STRING} ^.*(\[|\]|\(|\)|<|>).* [NC,OR] solution and did not have success.

  15. AITpro
    Member
    Posted 1 year ago #

    @Mark Bremmer - BPS Pro 5.3.3 was released yesterday that also automatically fixes this issue. If you are not seeing the upgrade notification in your WP Dashboard:

    1. Click on the "Updates" Link under your WordPress Dashboard panel (topmost left link is the Dashboard panel).

    2. Click on the Check Again button.

    3. Refresh your Browser.

    You should now see an upgrade notification displayed in your WordPress Dashboard for BPS Pro.

    If you still do not see an update/upgrade check notification in your WordPress Dashboard then go to the WordPress Plugins page and Refresh your Browser.

    If you still do not see a BulletProof Security Pro update/upgrade check notification in your WordPress Dashboard then deactivate any other security plugins you have installed on your website and go to the WordPress Plugins page and refresh your Browser.

    If you still do not see a BulletProof Security Pro update/upgrade check notification in your WordPress Dashboard then deactivate all plugins and go to the WordPress Plugins page and refresh your Browser.

  16. Mark Bremmer
    Member
    Posted 1 year ago #

    Perfect. All is working correctly again. Thank you!

  17. justatest47
    Member
    Posted 1 year ago #

    I'm having the exact same problem as OP brandonchicago. I was just about to post a new thread on this when I just saw this thread.
    So far I haven't been able to fix it. I am thinking about downgrading back to 3.4.2.
    3.5 is a real mess for me! ANY FIXES?
    And NO it's not a plugin nor a theme related issue! (already tested that out)

    UPDATE: Actually I can confirm that I am also using BPS plugin. So I think this issue has been found and fixed.

  18. justatest47
    Member
    Posted 1 year ago #

    Actually I've just discovered the root cause for this issue.
    I've fully deactivated BPS and reverted to the default .htacess but the issue persisted so it was NOT caused by BPS.

    I've deactivated mod_pagespeed from my server and now the Add Media button works.

    So, the issue is caused by BOTH wordpress 3.5 for not being fully compatibile with mod_pagespeed beta and by mod_pagespeed beta itself for not being fully compatible with wordpress 3.5...

    I hope a fix will follow soon in wordpress 3.5.1 because my server still uses the beta version of mod_pagespeed even though version 1.0 was finally released a few months ago and having pagespeed disabled is not good because the site loads really slow without it.

  19. Shimunto Sannyasi
    Member
    Posted 1 year ago #

    Thanks all for help...

    Thanks to attikon For his post (understand easy) for the news user of word press like me...

    i have a news portal where i used word press 3.5...

    http://www.ekusheynews24.com

  20. IliyanaStareva
    Member
    Posted 1 year ago #

    I deactivated the CKEditor and it worked; my problem now is that I do actually need the editor to publish new blog posts and edit them to look like the previous ones.
    So what now?

  21. saifulmuhajir
    Member
    Posted 1 year ago #

    I have the same problem and I added: define('SCRIPT_DEBUG',true); to wp-config.php file. But, the problem persists.

    The editor is back with toolbar. But, there's nothing on the toolbar. No icons, no shortcuts.

    I found these error:

    Uncaught TypeError: Cannot read property 'length' of undefined
    jQuery.extend.each
    e.widget
    (anonymous function)
    (anonymous function)

    Anyone can help?

  22. Chou
    Member
    Posted 1 year ago #

    Well I have the same issue (no post editor at all after upgrading WP to WP3.5 ) and I do NOT use the BP plugin so it can NOT be bulletproof related.

    Also, the problem persists in 3 different browsers, so it is NOT browser related either. I have other websites running on previous versions of WP with all the same plugins as the upgraded site and they are not showing this editor problem, so it can't be any particular plugin either.

    The best solution imho is to go back to a previous version of WP until this is properly solved. I don't like to make patchwork solutions on ht access files etc...

  23. AITpro
    Member
    Posted 1 year ago #

    @Chou - it could be a built-in/bundled plugin in your Theme. Do the normal/standard troubleshooting step of switching your Theme to the WP 2012 Theme. I am aware of 1 Theme author's Themes that have some issues - Themeforest Themes and there may be some others.

  24. saifulmuhajir
    Member
    Posted 1 year ago #

    In the end I suspect this occurred because of the theme. I ended up downgraded the WordPress while waiting for the theme update.

    Oh, and sorry for opening up the resolved issue.

  25. vividhaditya
    Member
    Posted 1 year ago #

    I too had the same problem. Deactivating all plugins didn't help. Removing .htaccess file from wp-admin folder too didn't help.

    But adding:
    define('SCRIPT_DEBUG', true);
    to the wp-config file solved the problem.

    But it has slowed down the admin side. Hopefully, there will be a permanent solution to it soon.

  26. pdguyonus
    Member
    Posted 1 year ago #

    Thanks AITPro,

    I too had BPS installed but had deactivated and removed the plugin a few months ago. It left the BPS .htaccess mods in place (unwittingly).

    I reinsalled BPS and activated the plugin using the default settings and now I can edit normally and use WP menus, media library etc.

    Thanks!

  27. Gerhard Lichtenauer
    Member
    Posted 1 year ago #

    The reason for my js-problems in the admin area after upgrading to WP 3.5 was the plugin "WP Facebook Timeline (MF Timeline)" (compatible up to: 3.2.1). Deactivating this plugin resolved it all.

  28. becomebecome
    Member
    Posted 1 year ago #

    XILZEN

    Your fix worked for me!

  29. apronstringsaflutter
    Member
    Posted 1 year ago #

    That worked for me too. Thank you!

  30. CouponCodePlugin
    Member
    Posted 1 year ago #

    I have used bulletproof for a while now and it is a bit of a nightmare when you have an issue, but that is because it is doing things that most of us do not understand, so it is not easy to isolate the cause. AITpro is very active and replies to my questions faster than paid companies. I will definitely be upgrading to pro.

    For the site I was having issues with, it turned out to be the theme which had a js item that was not being loaded and was causing the issue.

Topic Closed

This topic has been closed to new replies.

About this Topic