WordPress.org

Ready to get started?Download WordPress

Forums

post don't appear on blog page (31 posts)

  1. Prek
    Member
    Posted 1 year ago #

    Hi I'm new to WP and I'm trying to post a comment to a blog page, but it doesn't appear on the site. I can add the comment and then see it when I click "view page" but when I go to the live site it's not there.
    Any suggestions would be greatly appreciated!

    http://www.dreamingamerican.com/

    Thank You.

  2. Jen Mylo
    Key Master
    Posted 1 year ago #

    Can you please link to the specific post/page where you left the comment? The main page of the site doesn't help us debug.

  3. Prek
    Member
    Posted 1 year ago #

    Hi here is the page where I'm trying to post a common but is not going through.
    http://www.dreamingamerican.com/blog/

  4. Prek
    Member
    Posted 1 year ago #

    I have posted 2 commons there and when I go to post a new common I see them there and I click view their there but here is the link for it http://www.dreamingamerican.com/coming-soon/ , but when I go to check on the website life nothing shows below.
    http://www.dreamingamerican.com/wp-admin/edit.php

    Please try to help me out.

    Thank You so much.

  5. Jen Mylo
    Key Master
    Posted 1 year ago #

    We can't log in to http://www.dreamingamerican.com/wp-admin/edit.php because only site authors are able to do that. I'm a little confused... are you a visitor to the site and leaving a comment on the page at http://www.dreamingamerican.com/coming-soon/ or are you an author on this site and leaving comments from inside the admin at http://www.dreamingamerican.com/wp-admin/edit.php?

  6. Prek
    Member
    Posted 1 year ago #

    I'm an author on this site and leaving comments from inside the admin at http://www.dreamingamerican.com/wp-admin/edit.php?

  7. Prek
    Member
    Posted 1 year ago #

    i can give you the logging info if you want to take a look

  8. Prek
    Member
    Posted 1 year ago #

    I been trying for a day and still can't figure this out is driving me crazy. I hope you can help me out :)

    Thank You

  9. Andrew
    Forum Moderator
    Posted 1 year ago #

    You shouldn't give your credentials out to anyone. If you require someone to do it for you, you may be better asking http://jobs.wordpress.net .

  10. Jen Mylo
    Key Master
    Posted 1 year ago #

    Are the comments pending moderation? Depending on your comment settings, just because you're an author doesn't necessarily mean your comments are auto-approved. If you see an Approve link under the comment when you are in the admin, click on it. If the comment shows as approved in the admin, please take a screenshot showing that and reply with a link to the screenshot (you can use something like http://getcloudapp.com/ to post screenshots online).

  11. Prek
    Member
    Posted 1 year ago #

    thank you Andrew.
    Jen I hope you understood the question I replied back to you..

    waiting for your responds.

    Thank You.

  12. Jen Mylo
    Key Master
    Posted 1 year ago #

    @Prek. Yes, I understand what you are asking, but Andrew is correct, we don't want to log in to your site. Please look at what I described above, and post a screenshot if the comment is not waiting to be a approved so we can see what you see without logging in.

  13. Prek
    Member
    Posted 1 year ago #

    Sorry, I wasn't completely clear. It's actually an information page where I post news to the site, no one else can, so there wouldn't be an "approve" button. I go to the page from my dashboard and add the post. It shows when I click "view page' but not when I go to the actual site.
    Here is what the dashboard page looks like:
    https://www.dropbox.com/s/9oyie1yidnjdf3b/Feature%20Page%20Top.png?m

  14. Jen Mylo
    Key Master
    Posted 1 year ago #

    That screenshot is for a page, not a comment, so if you meant you were trying to publish a page vs a comment being left via the Discussion box on the editor screen, that wasn't clear.

    If you are talking about trying to publish a Page, click on the bar that says Publish in the upper right (of the screen that you captured in a screenshot) to open the box so we can see the Visibility and Publish status for the page. Post a new screenshot.

    If you are talking about leaving a comment on Page from within the admin, scroll down to show the area where you see the comment, and screenshot that.

  15. Prek
    Member
    Posted 1 year ago #

    sorry I send the wrong link
    below is the link.
    https://www.dropbox.com/sh/s39ykznxb2kz7e4/-vAopQIhkB?m

    Thank You.

  16. Prek
    Member
    Posted 1 year ago #

    Hi Jen I hope you got to see the new link I send to you.
    let me know what I should do please.

    Thank You.

  17. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Try deactivating your plugins and switching to the default WP theme to see if it works then. That may help narrow down the cause of the issue.

  18. Prek
    Member
    Posted 1 year ago #

    which Plugins I need to deactivate I have a lot of them.

  19. Jen Mylo
    Key Master
    Posted 1 year ago #

    The Coming Soon page appears on the live site. The Coming Soon page is the one you took screenshots of.

    Are you asking about the Coming Soon page, or the (no title) page? If it's the (no title) page, you need to take the screenshot of that page's editor (with the publish box open), not the Coming Soon page.

    Please be specific about the actual content you are not able to see on the live site.

  20. Prek
    Member
    Posted 1 year ago #

    Hi Jen
    thank you for getting back to me.
    There is no Coming Soon page. Coming Soon is a post on the Feature Film page. I post news to this page. The screenshots are as follows:
    1. The posts listing from the dashboard

  21. Prek
    Member
    Posted 1 year ago #

    Hi Jen
    thank you for getting back to me.
    There is no Coming Soon page. Coming Soon is a post on the Feature Film page. I post news to this page. The four screenshots you see are as follows:
    1. The posts listing from the dashboard (double click the middle one to see:
    2. The post itself
    3. What I see when I click on "view post"
    4. What is actually displayed on the site

  22. Prek
    Member
    Posted 1 year ago #

    https://www.dropbox.com/sh/s39ykznxb2kz7e4/-vAopQIhkB?m
    let me know if you get to view 4 pics there.

    Thank You.

  23. Jen Mylo
    Key Master
    Posted 1 year ago #

    Coming Soon (a post) displays on its own page (correctly) at http://www.dreamingamerican.com/coming-soon/
    Each post has its own standalone page where it appears separately from the list of posts.

    The navigation label on the left hand side of your site that says "The Feature Film" links to http://www.dreamingamerican.com/blog/ where one post labeled Home is displayed. If I click on the "Home" title (to check to see what that post's link will be, to see if there's something up with permalinks), it links back to the the front page of the site at http://www.dreamingamerican.com/ rather than to an actual post.

    1. Check your Settings -> Reading and make sure that where it says "Blog displays at most __ posts" it doesn't say "0" or "1".

    2. Either way, it seems like your theme may be coded incorrectly since the empty blog post that is showing at http://www.dreamingamerican.com/blog/shows "Home" as the title and links to the home page.

    The way you can check to see if it's your theme is to switch back to the default theme for a few minutes so you can see if the posts then show on the blog page. If so, then the problem is your theme.

    You say you have a lot of plugins on your site. Every one of them introduces the possibility of creating these problems (the theme issues may even be caused by a plugin). If switching the theme back to the default theme doesn't make the post appear, then it's probably a plugin. At that point, the way to figure out which one it is is to turn off all of the plugins, then turn them back on one at a time and check the site after each one to see which one causes the problem.

    Volunteers in this forum aren't able to do this for you; we can only point you to the directions on how to do it. Once you know what's causing the problem, we can potentially tell you how to fix it.

    If you want someone to do the checking and fixing for you, you would be better off hiring someone to take care of this for you.

  24. Prek
    Member
    Posted 1 year ago #

    thank you so much for taking your time to explain all this to me
    I just uploaded a screen shot for you to see the "reading settings"

    https://www.dropbox.com/sh/s39ykznxb2kz7e4/-vAopQIhkB?m

  25. Jen Mylo
    Key Master
    Posted 1 year ago #

    It's not your reading settings.... 10 posts per page should show the Coming Soon post. The problem is with what your theme is doing. You will need to follow the instructions above to see if it is the theme itself or if one of your plugins is compromising your theme's ability to do its job.

  26. Prek
    Member
    Posted 1 year ago #

    Hi Jen thank you for all your help I appreciated that.

    I uploaded one more picture to show you the themes I have if I switch to one of the themes just to see if the blog is working there I won't lose any of the work I put on the site so far when I got back to the theme I have now?

    https://www.dropbox.com/sh/s39ykznxb2kz7e4/-vAopQIhkB?m

  27. Jen Mylo
    Key Master
    Posted 1 year ago #

    You wouldn't lose your widgets or post/page content if you switched just to test the theme, they would remain in the dashboard even if they don't display the same in another theme, and when you switched back they'd be there.

    The theme you are using is not available through WordPress.org, so we have not tested it for functionality or security. Please contact the theme author at http://www.fabthemes.com/wallbase/ so they can help you fix the problem.

  28. Prek
    Member
    Posted 1 year ago #

    thank you again I did switch to a different theme it's not theme causing the problem because the blog didn't work there either.

    https://www.dropbox.com/sh/s39ykznxb2kz7e4/-vAopQIhkB?m
    I just post the few pictures for you to see of the plugins.

  29. Jen Mylo
    Key Master
    Posted 1 year ago #

    Turn off all plugins, then turn them on one at a time. Check the site after each one to see if it works or is broken. With all plugins off, it should work properly.

    Turn on the first plugin in your list, then look at the site to see if the post shows.
    If it does, then go back and deactivate that plugin. Turn on the next one, check the site, etc. When you check the site and it doesn't show the post, that's when you've found the bad plugin.

  30. Prek
    Member
    Posted 1 year ago #

    I turned everything off and that blog doesn't appear at all

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.