WordPress.org

Ready to get started?Download WordPress

Forums

P2 By Email
post by email cuts off content following an apostrophe (5 posts)

  1. pensato
    Member
    Posted 7 months ago #

    For instance, I sent a test email:

    Subject: This is a post by email
    Body: It’s interesting to see if this will work...

    The post went through OK, but the post reads:

    Title: This is a post by email
    Content: It

    Any thoughts about why that might be?

    http://wordpress.org/plugins/p2-by-email/

  2. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 7 months ago #

    That's really odd, I've never seen that before.

    If you create another email with an apostrophe in a different position, where does it break?

  3. pensato
    Member
    Posted 7 months ago #

    I've tried all kinds of stuff now in testing. It always, every time, breaks at the first apostrophe.

    I've tried disabling plugins (I thought maybe Markdown on Save Improved was messing with stuff), but even with all other plugins disabled, no dice.

    Any thoughts about where else to look?

  4. pensato
    Member
    Posted 6 months ago #

    Any further thoughts?

    I'm open to the possibility that the problem is in my server config, but I'm not sure where to begin looking...

  5. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 6 months ago #

    I don't have any good suggestions off the top of my head, unfortunately. The first thing I'd debug is the value of $message right before it's passed to wp_mail(). If it's intact, then the problem is either in wp_mail(), PHPMailer, or whatever utility you use to send emails on your server.

    Another thing you could do to debug is set up your WordPress install (with all plugins) on a completely different server environment and see what happens. If it reproduces, it's probably a code issue. If not, it's probably a server issue.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.