WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Post by Email (8 posts)

  1. bakuvia
    Member
    Posted 5 years ago #

    I've set my Writing settings and these are correct.

    Checking receipt of email manually using http://mydomain/wp-mail.php shows that message is received and gives following message:

    Author is blank@blank.com
    Author: 1
    Posted Title: Title of Message
    Mission complete: Message 1 deleted.

    I used the <iframe> code suggested in the Codex for 'post by email' as follows:

    <iframe src="http://mydomain/wp-mail.php" name="mailiframe" width="0" height="0" frameborder="0" scrolling="no" title=""></iframe>

    placing it in the footer.php file (tried it both before and after </body></html> tags. The message doesn't post to the blog, even on refresh.

    I tried also looking at the postie plugin but it was too complicated for me to figure out. I managed to upload it and activate it but the instructions are for an older version of WP and talk about configuting using Options in the Plugins panel and these aren't available in this version of WP.

    Has anyone been able to successfully get the 'post by email' function to work in WordPress 2.7. Can someone provide a sensible step-by-step instruction on how to force 2.7 to 'get' the posted mail?

  2. bakuvia
    Member
    Posted 5 years ago #

    Thanks to Crazyoval for help with this:

    What I did (step-by-step):

    In Settings > Writing - entered necessary details

    mail.example.com
    user@example.com
    password
    set default category

    Downloaded php file from here: http://trac.wordpress.org/export/9504/trunk/wp-mail.php (new php)

    Used Notepad and edit > find to locate phrase: 'set status to pending' and in line underneath changed post status 'pending' to 'publish'

    Saved file and uploaded to wp folder, replacing old file.

    Added <iframe> code to footer after html tag

    Set email in email to plain text and sent mail to system.

    This worked a treat.

  3. Sridhar2
    Member
    Posted 5 years ago #

    Hi buddy,

    I have followed all the step which you have told. But The post via email is not working for me.

    I have configured the settings for the pop, username and password in the writing page.

    Also I have sent an email which is plain in text, to that email address.

    But still not working. I have ran wp-mail.ph script after sending the email. but still it was not posted.

    Actaully I have the email account in netfirms. So I have tried using that server. Also I checked with gmail account. But still I am facing this problem. I am getting error as POP3 connect: Error [13] [Permission denied]

    will u please tell me a example with the port number so that i can use it.

    Thanks

  4. mightym@x
    Member
    Posted 5 years ago #

    I had problems with this but found out it was because I was trying to text my post in to the email account I set up for posting from. I found a helpful explanation here http://sinacism.com/2009/04/18/texting-to-post-now-works/

  5. fireandsalt
    Member
    Posted 4 years ago #

    Make sure you add a user under Users...Add new... With the e-mail address you are trying to send from.

    Example:

    If you are trying to post to your blog using a gmail account named thisisatestemailaccount@gmail.com then you need to create a new user in your blog with an email address of thisisatestemailaccount@gmail.com. Make sure he is an editor and then send an email from thisisatestemailaccount@gmail.com to thisismysupersecretemailaccount@gmail.com

    Fill in the Subject and the Body. Send in plain text, otherwise the post gets all garbled up.

    Then go to your wp-mail.php file and run it (or add the iframe as discussed in the codex to the footer).

    Happy posting!

  6. JT101
    Member
    Posted 4 years ago #

    Hi

    Fireandsalt. Can I just confirm. As written in the codex, I put my super secret account details in the writing section of wp-admin, but then the user is the account I use to send e-mails to that secret account (which is my normal e-mail account).?

    Thanks

    James

  7. OmeLaurus
    Member
    Posted 4 years ago #

    It works for me now (thank you !!), but i like the posts to appear directly on my site instead of being held back for review. Is this possible?

  8. MAzCastro
    Member
    Posted 4 years ago #

    Hi

    OmeLaurus, yes it is.

    Simply give your user a Role not less then Editor (Editor and Administrator Roles publish immediately, all other need posterior approval)

    Cheers!

    MAC

Topic Closed

This topic has been closed to new replies.

About this Topic