WordPress.org

Ready to get started?Download WordPress

Forums

Post by email (10 posts)

  1. mrosarionyc
    Member
    Posted 5 years ago #

    Hello. I've seen a few posts where people complain that the Post by email feature of WP doesn't work and I am still experiencing problems...

    Even after i created a new email account (hosted by google) and added all the pertinent information in the Post by email page, i get this error:

    POP3 quit: connection does not exist

    Anyone know what are the correct settings to make this work?

    I have:

    Mail server:
    pop.googlemail.com Port 995

    Login: full email address and the password. I even selected to which category should be posted...

    and no luck! anyone?

  2. JackDeth
    Member
    Posted 5 years ago #

    I have this exact same problem.

    Anyone have an ideas?

  3. sirryche
    Member
    Posted 5 years ago #

    i ruan into the same problem . when i used the address in the explorer
    http://example.com/installdir/wp-mail.php. i changed it to http://mywebsite.com/installdir/wp-mail.php and received the same error. i noticed that my wp is located in root and not a forder so when i used http://mywebbsite.com/wp-mail.php and took out the "installdir" then it pulled the emails form my email provider which is yahooo. hope this helps
    `

  4. bhallpm
    Member
    Posted 5 years ago #

    Thanks, sirryche!
    I spent HOURS wondering why this wouldn't work. YOur fix was immediate.

    Thanks again!

  5. JT101
    Member
    Posted 5 years ago #

    I don't know if anyone can help me any further. I cottoned onto Sirryche's suggestion straight away, and it doesn't work for me. Here is my link: http://gator868.hostgator.com/~rodders/wp-mail.php
    Based on the codex article: http://codex.wordpress.org/Blog_by_Email
    I have opted simply for the manual browser activation as mentioned above.
    I have tried google, yahoo, and yahoo business mail. I have tried SMTP, POP 3, and POP 3 SSL, I ensure the e-mail is sent in plain text, the administrator’s e-mail matches the one entered under the writing section, and the username is the full e-mail address.
    I don't know what else I can do. This is very frustrating.
    But, I am glad to see someone got it working with Yahoo, so clearly I'm missing something.
    I used pop.gmail.com with port 110, and 995.

    Please, someone come to my rescue here.......

  6. midds44
    Member
    Posted 5 years ago #

    instead of pop.gmail.com try
    ssl://pop.gmail.com
    port 995
    worked for me, but i had to find it on an external site!

  7. nbzyj1
    Member
    Posted 5 years ago #

    unlucky ,I got the same problem

  8. WalnutHill
    Member
    Posted 4 years ago #

    I am having the same issue as well....

    I tried with my own email addresses (mypostingemail@mydomain.com and mypostingemail@myotherdomain.com). Getting a 400 bad request or the POP3 error....

    Trying EVERYTHING with no love (been working on this issue alone foe about 3 hours so far today).

    If anyone has any more help or things to try, please post! I have tried every suggestion I could find.

  9. fireandsalt
    Member
    Posted 4 years ago #

    If your blog is on your main site, you use http://www.mysite.com/wp-mail.php
    If your blog is in a sub folder, you use http://www.mysite.com/blog/wp-mail.php
    * replace 'blog' with whatever the folder's name is.

    Also, make sure you are sending the e-mail from an account in your users with editor permissions. Example:
    Go to Users > Add new...
    Call the user Me at work, or Me going mobile, etc...
    Add your Name to the First and Last blocks
    This is the important part!!!!! type in the e-mail address you want to send from!
    Make this user an editor or admin

    Now, send an email from the e-mail account of the user you just added to your secret e-mail address you set up on the writing page (Settings...writing).
    Run the wp-mail.php script by typing the script path into your browser.

    If your post came out funky looking, be sure to send only plain text.

    If your post came over in a pending status, you sent it from an e-mail account that is not an editor or admin on your blog.

    I'd recommend setting the wp-mail.php script in the footer of your theme as explained in the Codex help page for sending via e-mail. Put the iframe in just before </body>.

    Happy posting!

  10. fireandsalt
    Member
    Posted 4 years ago #

    Alternatively, edit your wp-mail.php script by finding:

    // Author not found in DB, set status to pending.  Author already set to admin.
    		$post_status = 'pending';

    And replace it with:

    // Author not found in DB, set status to pending.  Author already set to admin.
    		$post_status = 'publish';

    Just be careful doing that though. By changing that portion of the code, you are allowing posts from any e-mail account in the world to start publishing posts automatically to your blog.

Topic Closed

This topic has been closed to new replies.

About this Topic