WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Post Auto-Save Eats my Web Browsers (11 posts)

  1. schellack
    Member
    Posted 5 years ago #

    When creating a new post or editing an existing post, at the point WordPress goes to auto-save the post, it starts doing a POST to http://mysite/wp-admin/admin-ajax.php over and over and over again from the jquery.js. This pretty much kills my web browser (IE6, IE7, FireFox 2, FireFox3, each on different PCs), causing the CPU usage to go through the roof and making it almost impossible to actually post anything or, especially, to edit a draft or an existing post.

  2. schellack
    Member
    Posted 5 years ago #

    Does no one else out there have this issue? I don't know if it's due to using a GoDaddy shared hosting account or not, as that's caused me weird issues in the past (where they might be blocking some things), but surely someone else out there uses the latest version of WordPress on a Godaddy shared hosting platform.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    I use WP on a GoDaddy shared host. It works with no issues for me.

  4. iridiax
    Member
    Posted 5 years ago #

    What plugins are you using? Try disabling all of them and see if the problem goes away.

  5. RandyPeterman
    Member
    Posted 5 years ago #

    I, too, have this issue. I have disabled all plugins but akismet, feedburner and wp-cache. Those three are running the latest version and the auto-save timer still loops too quickly. When I disable them, the bug still takes place.

  6. schellack
    Member
    Posted 5 years ago #

    I tried disabling my plugins too, but to no avail. Is there a way to stop/turn off the auto-save feature?

  7. schellack
    Member
    Posted 5 years ago #

    It would really be helpful to at least be able to turn off the auto-save functionality. Does anyone know, perhaps, what I should comment out in the PHP code to disable this?

  8. whooami
    Member
    Posted 5 years ago #

  9. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    schellack: Make certain that you upgraded the root wp-settings.php file. This is now known to cause the "blinking save/publish" issue, when you fail to upload all the WordPress files.

  10. schellack
    Member
    Posted 5 years ago #

    Thanks Otto42! Uploading the latest wp-settings.php seems to have corrected the issue. I guess I failed to update that file when I went from 2.5 to 2.5.1. I can now create new posts from my site instead of only being able to use ScribeFire. Woo hoo!

  11. ninjaboy
    Member
    Posted 5 years ago #

    For anyone that wants to turn off autosave, you can use the WP-CMS Post Control plugin over at http://wordpress.org/extend/plugins/wp-cms-post-control/

    It gives you an admin page that allows you to turn off the autosave feature, along with post revisions too. It also allows you to completely control every element of the write page, so you can hide unwanted items easily.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags