WordPress.org

Ready to get started?Download WordPress

Forums

Post author problems (18 posts)

  1. ghostfreak
    Member
    Posted 7 years ago #

    I recently added a new post to my blog and in the admin panel it shows a different author - I can't find my name in the 'change author' list - any ideas?

  2. ghostfreak
    Member
    Posted 7 years ago #

    I forgot to say that I'm using WordPress 2.1.

  3. ghostfreak
    Member
    Posted 7 years ago #

    Now everytime I create a post (when I'm signed in) it displays the author as another user and not myself (ghostfreak).

    Any ideas?!

  4. Michael
    Member
    Posted 7 years ago #

    I'm having this problem on one of my wordpress blogs as well. There is no author field when editing a post (or writing a new one).

    WP 2.1.2 on IIS 6 server. MySQL5, php4...

    What gives!?

  5. Michael
    Member
    Posted 7 years ago #

    I've discovered that the problem (for me) was that wp wasn't counting the default admin user as a second author, so it wasnt showing the author field. I added a new user and then the author drop-down showed up. Furthermore, once I added a first name onto the admin account it also showed up in the drop-down list.

    This seems like a bug to me. If a user (such as the default admin) has posts, he should be included in the list of authors (which, for that matter, should be visible) if there are any other authors...

  6. MsHutch
    Member
    Posted 7 years ago #

    I am also having this problem on one of my wordpress sites. The only author that shows is the user with the role of author. No "admin" user shows as a choice in the drop-down list.

    Anyone have any ideas?

  7. minou30
    Member
    Posted 7 years ago #

    Bizarre. Seems adding a first name to the admin user does indeed enable the "Author" box to appear on create/edit posts page. Worked for me.

  8. emclain
    Member
    Posted 7 years ago #

    I think you can make any change to the admin user, and it will fix this problem.

    I did it by checking the checkbox next to my admin user on the main Users page, selecting "Set the Role of checked users to: Administrator", and clicking "Bulk Update".

    The underlying problem seems to be that the "user_level" field in the database does not exist for the admin user, but changing the user causes it to be created. I suspect user_level might be a deprecated database field and so it's not always populated.

  9. therks
    Member
    Posted 7 years ago #

    I think you can make any change to the admin user, and it will fix this problem.

    Unfortunately didn't work for me.
    I was trying to create a page with the admin account, but in the Page Author dropdown it only had one username, a user with the Author role.
    What eventually worked for me was I created a new Administrator user, then set the Page Author to the original admin account (because now in the dropdown there were three users, admin, new-Admin, and the author that had always appeared before), then deleted the new-Admin.
    So far, so good. Glad I found this topic though. Took me forever to find it (although it was my own fault, I was searching wordpress.com :P).

  10. davincim
    Member
    Posted 7 years ago #

    I just discovered this problem on one my blogs. I was trying to create a page and my guest blogger was the only one showing as an option as page author.

    Once I edited MY profile (as admin), my name showed up just fine in the menu. All I did was add an initial to my last name.

  11. hummingcrow
    Member
    Posted 7 years ago #

    emclain:

    I think you can make any change to the admin user, and it will fix this problem.

    This happened to me as well. I added a new user and suddenly all the posts I had written while signed in as admin were listed as by the new user (also admin level), and my original admin user did not appear in the post author dropdown box.

    I went to the original admin user and changed the nickname, and that added the account back into the dropdown list and got the post attributions to revert back to the appropriate author.

    Hope this bug gets fixed. I thought I was going crazy!

  12. journeyguy
    Member
    Posted 7 years ago #

    Selecting my admin account, making sure I had first and last name in the blanks, and then clicking "Bulk Update" as specified above worked for me. WEIRD problem! First I've had like this with MANY WP blogs.

  13. NigelBrook
    Member
    Posted 7 years ago #

    I also recently had this problem on one of my blogs - the admin user not appearing as an option in the drop down author selection box.

    The bulk update fix suggested above seemed to fix it - easy when you know how!

  14. lcwhitlock
    Member
    Posted 6 years ago #

    Seems this is still a problem, as I am having the same thing happen to all of my blogs. As has been suggested, the bulk update for admin role fixed it.

  15. junedodge
    Member
    Posted 6 years ago #

    I have been creating posts and setting things up for my site. As I have time, I've been adding users - then I edit the pages to switch them to the author who is going to be maintaining the posts.

    This was working fine, then all of a sudden today when I added a new author. I was able to reassign one post - but when I went to change the next one when I scroll down to the author section all I see is my admin name - no one else's name is showing up. When I went to my other site where I have other authors the same thing, only my admin name is showing up as a choice to be author.

    I'm using 2.2.2 - my WP installed with Fantastico and that is as high as I can go for the revision. But for this problem the sites were working - now they are not... I hope I have added enough detail to this entry that someone can point me to what to do to solve this...

    BTW I tried adding a letter to my name and then updating it - and I click my name and clicked on bulk update as suggested in this thread.. didn't change anything the way I needed it.

  16. junedodge
    Member
    Posted 6 years ago #

    I figured by problem about not being able to change authors - since I was able to make one change for an author with my new machine it doesn't make sense to me - but here is new information.

    On my iMac G4 with OS 10.4.10 I can change the authors.
    On my MacBook Pro with OS 10.5 I can not change the authors.

    Luckily, I still have access to the older system so was able to make the change in who manages the pages - they even get credit for it at the bottom of each post...

    http:parentpage.org/sandiego

    Thanks.
    June

  17. junedodge
    Member
    Posted 6 years ago #

    New Information that means I can get rid of my old computer:

    On my iMac G4 with OS 10.4.10 using Firefox 2.0.0.8, I can change the authors.

    On my MacBook Pro with OS 10.5 using Firefox 2.0.0.8, I can not change the authors.

    On my MacBook Pro with OS 10.5 using Safari Version 3.0.4 (5523.10), I can change the authors.

    Hope this helps someone.

  18. iBigfoot
    Member
    Posted 6 years ago #

    I have a strange problem as well. After changing some older articles to a new author suddenly all articles have been deleted (or not there - perhaps there are not deleted)...

    Any ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags