WordPress.org

Ready to get started?Download WordPress

Forums

Post 3.5 Update Error "Missing Argument 2" (6 posts)

  1. OSPF.office
    Member
    Posted 1 year ago #

    Hello,

    I am a novice user of wordpress, and I was hoping you could give me some case-specific pointers on the error that has appeared after I upgraded to 3.5.

    "Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/79/9908779/html/dev/wp-content/themes/linen_pro/functions/linen-extend.php on line 379 and defined in /home/content/79/9908779/html/dev/wp-includes/wp-db.php on line 990"

    What does this mean?
    I tried the steps with plug ins and the browser cache, but am hesitant to switch themes in case I lose more of my work.

    Any help would be greatly appreciated! I am using the fantastic linen theme by the Theme Foundry.

    Thank you,

    Caitlin

  2. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

  3. OSPF.office
    Member
    Posted 1 year ago #

    Thank you for the quick response!

    I followed the instructions here:
    http://make.wordpress.org/core/2012/12/12/php-warning-missing-argument-2-for-wpdb-prepare/

    And now I'm getting this:
    Fatal error: Call to undefined function wp() in /home/content/79/9908779/html/dev/wp-blog-header.php on line 14

    GoDaddy says they can't help me and to contact WordPress. Any further ideas?

    Thank you for your help!

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    I'm sorry but as you are using a commercial theme, you need to seek support from the theme's developer/vendor. We do not support commercial themes here.
    http://thethemefoundry.com/support/

  5. OSPF.office
    Member
    Posted 1 year ago #

    Ok, thank you!

  6. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    https://thethemefoundry.memberful.com/auth/sign_in is where your theme support is - since it is a theme problem and we don't support commercial themes.

    The link for developers has been there over a month so your theme most likely has an upgrade.

    You should go back to your original wp-config file.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags