WordPress.org

Ready to get started?Download WordPress

Forums

Links shortcode
[resolved] Possibly incompatibility with Mime Type Link Images plugin? (2 posts)

  1. MGmirkin
    Member
    Posted 1 year ago #

    I'm not sure which plugin is causing the problem, but you can see it here:

    http://www.eubootcamp.info/links/

    The link to the Electric Comet seems wonky, with the PDF icon hidden partly behind the link.

    But the Mime type icons display properly on other pages than the Links page.

    For instance here:

    http://www.eubootcamp.info/sourcebook/archives/

    Where all mime type images display correctly AFTER the link. The only difference between the pages that I can think of is that the Links page output is governed by the Links Shortcode plugin and maybe it outputs things in some non-standard way?

    Don't know...

    Any thoughts on how the plugin might do things in a way different than usual? Has anyone else mentioned incompatibility issues?

    Love both plugins. Would hate to lose either one. But need them to play nice together. ^_^

    Posted the problem over there too, so they're also aware of the issue. Hopefully one or the other can figure out the issue and fix whatever incompatibility might exist?

    http://www.wordpress.org/support/topic/possible-incompatibility-with-links-shortcode-plugin-not-sure-which-is-causing

    Thx in advance,
    ~MG

    http://wordpress.org/extend/plugins/links-shortcode/

  2. Maarten Swemmer
    Member
    Plugin Author

    Posted 1 year ago #

    Hello MG,

    I just took a look at the page and in Firefox it looks OK. From the response to the issue you posted on the other plugin, I understand that you have fixed the issue via a work around. Below I describe a permanent solution that does not require changes to the other plugin.

    If I understand correctly the Mime Type Link Images plugin uses some JavaScript to add an image to each link where necessary, using CSS:

    .mtli_pdf {
        background-image: url("../images/pdf-icon-16x16.png");
    }
    .mtli_attachment {
        background-attachment: scroll;
        <strong>background-position: right top;</strong>
        background-repeat: no-repeat;
        display: inline-block;
        height: 16px;
        <strong>padding-right: 19.2px !important;</strong>
    }

    The bold statement above is what makes sure that the icon is shown right of the text, instead of on top of it.

    Basically the Links Shortcode plugin outputs links exactly as specified in the template (on its Settings page). You seem to have something in the template like this:
    <div class="links_sc">
    The CSS that comes with the Links Shortcode plugin defines padding:0 for class 'links_sc', apparently by default overruling what is stated in bold above.

    By replacing <div class="links_sc"> by <div> in the the Template section of the Links Shortcode settings page, this issue can be solved. It does not hurt other functionality because you do not display the Facebook button with your links.

    Please try it and let me know if this is the permanent fix.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic