WordPress.org

Ready to get started?Download WordPress

Forums

Posts 2 Posts
Possible incompatibility with NextGEN gallery plugin (7 posts)

  1. baia
    Member
    Posted 11 months ago #

    I'm using WP 3.6 and Posts 2 Posts plugin 1.6.2. I have one main CPT called 'participant' which is connected to 2 other CPTs called 'event' and 'group'. When viewing a particular 'participant' post, I normally see 2 boxes in the sidebar: 'connected events' and 'connected groups'.

    Since I updated WP and all plugins including P2P (edit: and NextGEN gallery, which seems to be the one conflicting with P2P), I now have this error message in these 2 boxes:

    WordPress database error: [Unknown column 'ids' in 'field list']

    SELECT
        wp_posts.*, wp_p2p.*
    FROM wp_posts
    INNER JOIN wp_p2p
    LEFT JOIN wp_p2pmeta AS p2pm_order
        ON ( wp_p2p.p2p_id = p2pm_order.p2p_id AND p2pm_order.meta_key = 'order' )
    WHERE 1=1
        AND wp_posts.post_type = 'event'
        AND (wp_posts.post_status <> 'trash' AND wp_posts.post_status <> 'auto-draft')
        AND (wp_p2p.p2p_type = 'participant_to_event'
            AND wp_posts.ID = wp_p2p.p2p_to
            AND wp_p2p.p2p_from IN (
                SELECT ids
                    FROM wp_posts
                    WHERE 1=1
                        AND wp_posts.ID IN (1889)
                        AND wp_posts.post_type = 'participant'
                        AND (wp_posts.post_status = 'publish'
                            OR wp_posts.post_status = 'future'
                            OR wp_posts.post_status = 'draft'
                            OR wp_posts.post_status = 'pending'
                            OR wp_posts.post_status = 'private')
                ORDER BY wp_posts.post_date DESC )
            )
    ORDER BY p2pm_order.meta_value+0 ASC, wp_posts.post_date DESC

    http://wordpress.org/plugins/posts-to-posts/

  2. psopacua
    Member
    Posted 11 months ago #

    Hi,

    I am having the same problem.
    Did you already found an fix for this?

    Kindly regards,

    P. Sopacua

  3. psopacua
    Member
    Posted 11 months ago #

    Hi,

    At this moment i fixed it by editing the posts 2 posts plugin.
    Core/Query.php line 129 -> fields => 'ids' -> fields => 'id'.

  4. Milan Stosic
    Member
    Posted 11 months ago #

    Thanks for this temporary solution.

    My issue was that when NextGen Gallery 2.0.11 was activated I didn't see any realation I previously made - not on backend or frontend.

    I can see sidebar widgets for making connection but when I save post widgets are blank like nothing is saved. On front-end I get blank slate info that still no connections are made.

    When I deactivate NextGen Gallery plugin everything works ok, and now I've changed field ids->id and it works ok even when NextGen Gallery is activated.

    This is for sure a temporary solution.

  5. scribu
    Member
    Plugin Author

    Posted 11 months ago #

    Did anyone think of asking the NextGen Gallery developers about this?

  6. baia
    Member
    Posted 11 months ago #

    @scribu: well, nope :) Personally I think NextGEN is a high quality plugin so I decided to go for the native WordPress gallery instead, and leave your plugin (P2P) intact.

  7. baia
    Member
    Posted 11 months ago #

    @scribu: nope. I think NextGEN isn't a high quality plugin so I decided to go for the native WordPress gallery instead.

  8. closemarketing
    Member
    Posted 10 months ago #

    For me, i'm trying to migrate from Nextgen Gallery to native WordPress.
    I deactivated the Nextgen plugin and it works fine.

Reply

You must log in to post.

About this Plugin

About this Topic