WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Possible Htaccess file issue - MU site not working (3 posts)

  1. MichielAndreae
    Member
    Posted 2 years ago #

    Hi all,

    I've set up a couple WordPress multisites in my time so I know how to do it. This time I'm setting up a multisite at another hosting and it's not working for some reason.

    I've already been in touch with my hoster and the do support wildcard domains. I checked with them and we made sure they are set up correctly.

    Here's the situation:
    My main domain is InMaastricht.com. I've enabled the multisite network setup there and completed it. I can access the Network Admin section.
    I've added the right rules to the Wp-config file and to .htaccess.

    When I create a subdomain now and try to visit it I see the regular Apache page. An example can be seen at test.inmaastricht.com. When I try to visit test.inmaastricht.com/wp-admin I get a 500 Internal Server error.

    The hosting company said it's probably the rewrite rules on my .htaccess file. Unfortunately I don't have enough knowledge on how to do fix the file to make sure it works. Here's what currently in my .htaccess file:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    I have no clue what to do next. I really need the site to work and I hope someone here can help me fix it.

    Thanks in advance for your time and expertise.

    Michiel

  2. You set up wildcards wrong.

    test.inmaastricht.com needs to point to whereever inmaastricht.com is installed. And this is NOT how subdomains are defaulted.

    So for example, if you have /public_html/ as your main html root, when you make test.inmaastricht.com, it thinks you want to use /public_html/test

    Just delete /test and off you go.

    For wildcards, just make sure that it also points to /public_html/

  3. MichielAndreae
    Member
    Posted 2 years ago #

    Hi Ipstenu,

    Thanks! I changed the settings on the wildcards and the domains came to live. It took me hours of looking and I'm very happy with you helping me out. Much appreciated and many thanks!

    Michiel

Topic Closed

This topic has been closed to new replies.

About this Topic