WordPress.org

Ready to get started?Download WordPress

Forums

Simple Fields Map extension
Possible bug in static maps (4 posts)

  1. PioneerSkies
    Member
    Posted 1 year ago #

    I've seen that generated urls

    [static_maps] => Array
                    (
                        [thumbnail] => http://maps.googleapis.com/maps/api/staticmap?sensor=false¢er=45.0894334,7.68598350000002&zoom=16&size=150x150&scale=1&maptype=roadmap&markers=size:mid|color:red|45.0894334,7.68598350000002
                        [medium] => http://maps.googleapis.com/maps/api/staticmap?sensor=false¢er=45.0894334,7.68598350000002&zoom=16&size=300x300&scale=1&maptype=roadmap&markers=size:mid|color:red|45.0894334,7.68598350000002
                        [large] => http://maps.googleapis.com/maps/api/staticmap?sensor=false¢er=45.0894334,7.68598350000002&zoom=16&size=1024x1024&scale=1&maptype=roadmap&markers=size:mid|color:red|45.0894334,7.68598350000002
                        [news] => http://maps.googleapis.com/maps/api/staticmap?sensor=false¢er=45.0894334,7.68598350000002&zoom=16&size=670x350&scale=1&maptype=roadmap&markers=size:mid|color:red|45.0894334,7.68598350000002
                    )

    have one "¢" char broking the url; it works with "&" instead. Just my problem?

    Bye :)

    http://wordpress.org/extend/plugins/simple-fields-map-extension/

  2. Pär Thernström
    Member
    Plugin Author

    Posted 1 year ago #

    ha! interesting: it's real output is "sensor=false&center=45"...
    So it's "&cent" that's becoming the "¢" char. Do you have any html-escaping taking place somewhere, like htmlentity() or esc_html() or similar? Try to output the value as un-processed/modified as possible..

    Let me know if you find anything!

  3. hakerdesign
    Member
    Posted 11 months ago #

    hi
    im trying to make the map work

    <?php
    $selected_value = simple_fields_get_post_value(get_the_id(), array(1, 2), true);
    echo "Phone: $selected_value";
    ?>

    im getting array instead of a map

    this is the code im using it works great with all other field
    map isnt working

    how can imake it work

    what am i doing wrong

    tnx

  4. Pär Thernström
    Member
    Plugin Author

    Posted 11 months ago #

    Try this:

    print_r($selected_value);

    and you will see what it contains. somewhere among all values there will be something useful!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.