WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Possible Bug (24 posts)

  1. crazyregcomics
    Member
    Posted 5 months ago #

    I installed this plugin on a site I built for a friend over a year ago. I upgraded to Pro and got a lot of support from you guys during the teething stages of the website's construction.

    I think I've found a bug and I wanted to let you know. On the website, we use a widget calendar and a full calendar. The widget can be seen on most pages, such as this: http://painkillerbookings.com/pk/ (it's on the left next to the About section).

    And the full calendar can be seen here: http://painkillerbookings.com/pk/gig-guide/

    Anyways, the possible bug is this: In Events > Settings > Formatting > Calendar, under the "Calendar Day Event List Settings" section, we had "Calendar events/day limit" set to 1. But this was effectively disabling the "more gigs..." link and the date link from showing a full list of events that occur on the same day as other events. So any day that had 2 or more events, only one event would show.

    But when I delete the 1 from "Calendar events/day limit" we get the list working as it ought to (when clicking on the date. However, the "more gigs..." link is now gone. Also, all events show in the full calendar, making the calendar layout a lil bloated for days with many events.

    Could it be another setting clashing with this?

    http://wordpress.org/plugins/events-manager/

  2. angelo
    NetWebLogic Support
    Posted 5 months ago #

    it works for me? can I know what is your current EM and WP FullCalendar please?

  3. crazyregcomics
    Member
    Posted 5 months ago #

    EM version is 5.5.2, and I just updated WP to 3.8.1.

    The full calendar can be seen here: http://painkillerbookings.com/pk/gig-guide/ Sorry, is that what you wanted to see?

  4. caimin_nwl
    NetWebLogic Support
    Posted 5 months ago #

    Are you using the WP FullCalendar plugin, or just the calendar option that comes with Events Manager?

  5. crazyregcomics
    Member
    Posted 5 months ago #

    Oh, I don't actually have the WP FullCalendar! I didn't know of it's existence. I'm using the full calendar built in with EM...

    This is the shortcode I'm using:

    [events_calendar full=1 long_events=1]

    Maybe the long_events bit is conflicting?

  6. angelo
    NetWebLogic Support
    Posted 5 months ago #

    maybe you can try EM dev version 5.5.2.1 - To upgrade to the dev version see here – http://wp-events-plugin.com/documentation/upgrade-dev-version/

  7. crazyregcomics
    Member
    Posted 5 months ago #

    Ok, just installed and tried WP FullCalendar and it doesn't appear to be working. I'm using the following shortcode for it, but nothing shows up:

    [fullcalendar]

    But honestly, I don't know what I'm meant to see or if WP FullCalendar is meant to be able to use and display the events I have created with EM. I'm surely missing something basic... Any suggestions?

    Either way, I've just enabled the dev version of EM, and have updated to dev vers 5.5.2.1.

    It hasn't helped. I went into Events > Settings > Formatting, then into Calendar. Under "Calendar events/day limit" I changed the empty field to 1, saved changes, previewed website, and it the calendar displays correctly, but when I click on the "more gigs..." link or the date that I know has more than 1 event, I am taken to the first event of that day. Therefore there is no way to see the other events on that day. :(

  8. caimin_nwl
    NetWebLogic Support
    Posted 5 months ago #

    Can you paste a link to the page with the "more gigs..." problem?

    I went to http://painkillerbookings.com/pk/gig-guide/ and can't see that problem. Thanks.

  9. crazyregcomics
    Member
    Posted 5 months ago #

    Hmmmm I can, except it means I have to screw up the site. Basically, when I set the calendar to show only 1 event per day, the "more gigs..." link appears, and clicking that or the date SHOULD take you to a list of THAT DATE'S events. Instead it takes you to the first event on that date. All other events are inaccessible.

    So I have turned this off because people go to this site frequently and they are not going to be able to access these events.

    If you can tell me when you are likely able to do this I can turn it on for say an hour or so, but I really don't want to leave it this way for a full day.

    sorry, I know it must sound like I'm being fussy, but I just worry that the functionality of the site is somewhat at risk. If you get me...

  10. caimin_nwl
    NetWebLogic Support
    Posted 5 months ago #

    Know what you're saying but it might be difficult to time it just right :)

    It might be worth checking whether or not it works without WP FullCalendar running.

  11. crazyregcomics
    Member
    Posted 5 months ago #

    Totally understand. I will talk to the website owner about maybe putting the Gig Guide offline for a day.

    In the meantime, I'd like to give WP FullCalendar another shot, but should it simply work automatically, cos it didn't for me...

  12. angelo
    NetWebLogic Support
    Posted 5 months ago #

    when I set the calendar to show only 1 event per day, the "more gigs..." link appears, and clicking that or the date SHOULD take you to a list of THAT DATE'S events. Instead it takes you to the first event on that date. All other events are inaccessible.

    - can you try this option, Events > Settings > Formatting > Calendar > Show list on day with single event =Yes

  13. crazyregcomics
    Member
    Posted 5 months ago #

    Hi again, sorry for not getting back to this sooner.

    Angelo_nwl, it is already set to Yes.

    Caimin_nwl, I'm going to enter 3 for the number of events on each calendar day. Currently it is blank so all events will show. I will revert it back after 24 hours. Is enabling this tomorrow (Feb 4th) at 7pm, UTC+10:00 time, enough time for you to have a look?

  14. caimin_nwl
    NetWebLogic Support
    Posted 5 months ago #

    Can't promise, but if it's around this time tomorrow I should be able to take a look.

  15. crazyregcomics
    Member
    Posted 5 months ago #

    That's perfect, thanks! :)

  16. crazyregcomics
    Member
    Posted 5 months ago #

    It is done. :) Here's the link again: http://painkillerbookings.com/pk/gig-guide/

    And a bit of info... Feb 7th has 2 events and Feb 8th has 5 events.

  17. caimin_nwl
    NetWebLogic Support
    Posted 5 months ago #

    Just looking at it now. I'm getting the same thing when I replicate what you've done, so I think it's an oddity which I'll mention to Marcus.

    As a workaround, you could make a copy of the calendar-full.php template found within /events-manager/templates/templates and then modify the copy around line 45. That's where the "more gigs" link is printed.

    Let us know if you need more help with this.

    Make sure you use a copy of the template to keep it safe when the plugin is upgraded:
    http://wp-events-plugin.com/documentation/using-template-files/

  18. caimin_nwl
    NetWebLogic Support
    Posted 5 months ago #

    Just a quick update: Marcus is going to look into this shortly.

  19. crazyregcomics
    Member
    Posted 5 months ago #

    Thanks! I've put the calendar back to NOT showing the "more gigs..." link. Would you like it switched back so Marcus can see the error?

  20. angelo
    NetWebLogic Support
    Posted 5 months ago #

    no need, we already let Marcus know about this.

  21. crazyregcomics
    Member
    Posted 5 months ago #

    Hi guys. I'm looking around line 45 of calendar-full.php, but not really sure what I'm meant to be seeing or changing, so I'll leave it alone for now! :)

  22. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 months ago #

    hi, sorry for the delay, this has been fixed locally and it'll be pushed out to a dev version most likely by tomorrow (5.5.3.4)

  23. angelo
    NetWebLogic Support
    Posted 2 months ago #

    Sorry for the delay in getting back to you, we've just released EM 5.5.3 and this issue should now be resolved. Thanks for your patience.

    If you can confirm the issue is resolved, that'd be appreciated.

  24. crazyregcomics
    Member
    Posted 2 months ago #

    All good regarding the delay. Just tried to upload the ZIP and I got this error message:

    The uploaded file exceeds the upload_max_filesize directive in php.ini.

    Never seen that before...

Reply

You must log in to post.

About this Plugin

About this Topic