WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] Possibility to group translations of same post/page/etc. (13 posts)

  1. W00tgnome
    Member
    Posted 1 year ago #

    I might have overlooked it, but if not I think it would be a great idea to add a setting that allows grouping of posts/pages/etc. based on the post/page/etc. they are a translation of.

    For example:
    - I create the page "Products" in English.
    - I create a translation of this page in Danish called "Produkter".

    Rather than now having two pages (one for each translation of "Products") there should only be one "Products" page if this "grouping" setting is enabled - and the translations should only be accessible through the translation buttons for this page.

    The translation displayed could be be selected using the prioritized list that is set up in Settings => Languages.

    The idea is simply to reduce what could become a big mess in the pages/posts/etc. lists.

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    You have the possibility to display your posts / pages (and other contents on admin side) in only one language by using the menu language in the the admin toolbar on top of your screen.

    I believe it does more or less what you want.

  3. W00tgnome
    Member
    Posted 1 year ago #

    Ah, I did overlook something. It'll suffice, just need to let my users know it's there.

  4. LittleBigThings
    Member
    Posted 1 year ago #

    First of all, GREAT multilingual plugin, thanks Chouby!

    I have an observation concerning the above question. It is indeed possible to choose the content pages by language, but it is only possible for the original administrator, is it right? For other users it did not seem to work for me.

  5. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    The language filter should not depend on the user role. At least it is tested for administrator and author roles and work with both for me. Whith which user role have you issues?

    The only restriction Polylang manages is the access to the languages pages (authors should not be able to modify site wide settings).

  6. LittleBigThings
    Member
    Posted 1 year ago #

    Thanks for the quick reply!

    In fact I tested it with different kind of users, also with a newly created administrator. When I tried to choose the right language, the radio buttons remain checked and nothing happens.

    The only special thing about the website is that the qTranslate plugin was installed. This plugin was however deactivated and deleted before installing your plugin.

  7. Evatt
    Member
    Posted 1 year ago #

    Strings do not show as tramslated. Is there anything you can do about it? If not, then instead of donating this plugin, I will need to buy another one.
    Thanks.

  8. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    @LittleBigThing, could you try with twenty twelve instead of your theme and all other plugins de-activated?

  9. LittleBigThings
    Member
    Posted 1 year ago #

    Hi Chouby,
    I have tried with twenty twelve and it did not work either.

    I use a somewhat modified twenty eleven theme by the way, so I suppose that does not make much difference.

  10. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    And what about other plugins which could conflict?

  11. LittleBigThings
    Member
    Posted 1 year ago #

    I don't use any plugins yet. I have just started working on this site. It is in a local environment using Xampp. I was testing multilingual options: qTranslate first and then your Polylang.

  12. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    I am really sorry. I can't reproduce the bug. I tested with several users with different roles (contributor, author, other admin...) and it always work. Though I don't believe that qtranslate could interfere when it is deactivated.

  13. LittleBigThings
    Member
    Posted 1 year ago #

    If you cannot reproduce the problem then probably I did something wrong! I'll start over, I am not yet that far anyway and I can use some practice. :-)
    Thanks for the nice plugin anyway! I'll let you know whether it is fixed!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags